Switching Modes via CAT

  • 1
  • Problem
  • Updated 5 years ago
Switching modes via CAT software results in odd frequency offsets.

I am using flrig and using selecting TS-2000 since there is no FlexRadio option. In the screenshot example, switching from USB to AM, the bandwidth widens for AM, but the offset does not change from USB.

Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes

Posted 5 years ago

  • 1
Photo of W5XZ - dan

W5XZ - dan

  • 564 Posts
  • 83 Reply Likes
Robert, when i use DXLab Commander to put me on the 'right' band and mode, it DOES seem to work...

FWIW...73
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Also choosing WWV in the SmartSDR band switcher should select AM instead of USB.
Photo of W5XZ - dan

W5XZ - dan

  • 564 Posts
  • 83 Reply Likes
agree, but every time here, it's dead flat zero beat on ssb...
Photo of Dave - WB5NHL

Dave - WB5NHL

  • 274 Posts
  • 61 Reply Likes
Bob, As you note, Dave Freese has not added 6000 to flrig. Fldigi does allow both freq, mode and filters to be selected via SmartCAT using the the XML file that FLEX released. Download from Dave's FLDIGI site.
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Smart CAT works fine, (The FA command returns the proper frequency)

flrig kinda works, I can change frequencies okay, but changing modes is flaky.

I downloaded the SmartSDR.xml file, put it in the fldigi.files/rigs folder and selected it in Rig description file part of the RigCat tab of the Fldigi configuration and selected the com port that matches the one in SmartCAT, but alas choosing initialize does not connect Fldigi to the Flex 6700.

Fldigi 3.21.76AC
Photo of Dave - WB5NHL

Dave - WB5NHL

  • 274 Posts
  • 61 Reply Likes
Bob, initialize works fine for me. Make sure the communications parameters are correct, defaults won't work.
Obviously, check the Use RigCAT box

Here are the ones that work for me (some may not be critical)
Baud Rate 9600
Stop Bits 1
Retries 2
Retry Interval 10
Write Delay 50
Check Commands Echoed, Restore Settings, VSP Enable
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Dave,
Checking RigCat did work. I think previous times I had RigCat checked I may not have had SmartCat properly working.

The other settings make no difference. Only selecting that XML file, com port and RigCat.

Thank you.

Also changing modes works fine, this topic can be closed.