SteppIR SDA2000 to Flex-6400 USB issue

  • 1
  • Question
  • Updated 6 months ago
  • (Edited)
I have two different brand FTDI cables and a the SteppIR S12 cable. For some reason I cannot get the either FTDI cables to communicate between the SteppIR and the 6400. The USB log does show activity though. I am using a SteppIR S12 cable too.

The USB cables are shown in the photo. The SDA2000 is set to data in/out 9600 Kenwood. Autotrak is turned on on the Steppir. The S12 is plugged into the data in (top port) on the 2000.

BTW the S12 cable worked with my desktop hooked into a serial port.

Any thoughts on what I am doing wrong? It seems to be set up correctly per the Flex USB Cables Interface for the FLEX-6000 PDF document.



Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes

Posted 6 months ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 523 Posts
  • 179 Reply Likes
Zack,

I am running two SteppIR antennas here from the back of the radio. One controller is a SDA 100 and the other is a SDA 2000. Using a FTDI cable I wire it myself like the attached diagram. Note: you must jumper pins 7 and 9. 

Controllers are set up for Kenwood 19.2 kbs though the baud rate doesn't matter.



Make sure you are using the Data OUT  RS232 connector on the back of the controller. 

Your USB settings look OK. I use TX ANT 1 and ANT 2 for tracking the antennas. 

Let me know if you need more help.

73,

Mack
W4AX
Alpha Team
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
I took the DB9 covers off and found which one had the jumper on 7 & 9. Then I put that side in the data in on the 2000 and it talks now. Thanks! Oh and I labeled both ends of the S12 cable so that I can tell where to plug it the next time I rewire my setup.
This is going to be sweet as I can now sit in my living room and use a laptop and have the 2000 track the rig. 
(Edited)
Photo of Craig - KØCF

Craig - KØCF

  • 210 Posts
  • 75 Reply Likes
You also need a null modem adapter on the KPA-500.
Photo of Michael Walker

Michael Walker, Employee

  • 1056 Posts
  • 314 Reply Likes
I can see that on your KPA500, the radio is sending commends to the KPA500, but the KPA500 is not responding.  

This is why you need a null modem cable on the KPA500.

Mike
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
I do have a null modem adapter on the FTDI cable to the KPA500. The 500 is set to radio-serial, serial pol-on and RS232 x 9600. Still not talking.
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
Oh the frustration. The 2000 is tracking but the SWR is skyhigh at 5.91. All bands are high.  Did a calibration on the 2000 but it made no difference.  This is just great
Photo of Mack McCormick

Mack McCormick, Elmer

  • 523 Posts
  • 179 Reply Likes
Retract your elements then do a calibration twice. That should fix it. Any arrows stored on the controller?
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
The calibration worked but the antenna no longer tracks. AutoTrk is on BTW. This is so frustrating.
(Edited)
Photo of Mack McCormick

Mack McCormick, Elmer

  • 523 Posts
  • 179 Reply Likes
We will get it working. Screen shot the USB logs and settings
Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
After I reset the radio i found that the baud on the rig USB was set to 38400. Once I found that I put it back to 9600 and all is good. 

This is so nice being out of the ham shack dungeon and in the living room with the wife. Now she is less of a radio widow. 
(Edited)