SSDR v2 remote CAT using TCP control of digital applications

  • 1
  • Question
  • Updated 1 year ago
We know from earlier posts by Peter, VE3LTI, that Flex Smartlink  remote audio can be fed to digital mode application by using VAC from www.software.muzychanko.net/eng/vac.htm.

My question is how to configure SDRCat to control digital application such as WSJT when going remote?  For remote I have configured the CAT dialog box for Slice A, TCP, port 60010.  I have port forwarded 60010 in  my home router to the Flex using its static IP address. 

I can bring up the Flex 6500 via Smartlink but the remote Cat dialog never shows the radio as being connected.

BTW.  For LOCAL operation I use the Flex6xxx as the radio and 127.0.0.1:60010 in the network setting of WSJT.  With these settings the Flex is recognized and WSJT seems to work.  I find it odd, however, that setting the radio setting of WSJT to the Flex static IP address plus the port will not work.

Any recommendations?

Bob
K6MBY
Sequim, WA
Photo of K6MBY

K6MBY

  • 23 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Jay / NO5J

Jay / NO5J

  • 1514 Posts
  • 222 Reply Likes
Bob

Yeah, it needs to connect to SmartCAT, which runs on a PC, so would need to use an IP that PC uses. not the radio, I "Think" the radio normally only allows connections from GUI clients, SmartCAT, and DAX. and FRStacks. all of which are using the API to communicate with the radio.

WSJT-X which uses Hamlib, speaks CAT to SmartCAT which translates CAT into the API commands the radio understands.

Assuming you will be running WSJT-X on a remote PC, that PC might be the machine that needs to run SmartCAT. Which would explain the usage in the WSJT-X configuration of 127.0.0.1 for the IP, along with whatever TCP CAT port you have configured for that instance of SmartCAT.

You need SmartCAT to translate CAT to API, so it will need to be running on a PC somewhere.

The part I'm unsure about is getting a remote WAN side instance of SmartCAT to connect to your radio on the LAN side. The radio listens and connects using port 4992, so I'd assume  4992 or possibly a range of ports, including 4992 will need a port forward through your WAN/LAN router firewall for the IP assigned to the radio.

I've seen Community members claiming it's possible to work digital apps remotely, If they can do it, everyone should be able to do it.

I'm ok with trying to setup the port forwards to my radio, in my router firewall, which might permit you to connect your SmartCAT/WSJT-X remote PC to my LAN side radio. for experimenting.

I figure the actual setup is easy and simple. It's the explaining and understanding the setup part, that's complicated.

The complication I haven't got a clue about is how to configure a remote SmartCAT to connect to a WAN IP, instead of a LAN IP local to it.

73 Jay / NO5J
(Edited)
Photo of K6MBY

K6MBY

  • 23 Posts
  • 0 Reply Likes
SmartSDR CAT is SmartLink enabled.  Just connect CAT to the SmartLink radio and it works exactly like it does on the LAN.  No additional router configuration is needed .

Tim, this does not function, for me,  as you describe.   Working remotely the "Radio Not Connected" icon within the SmartCat dialog box continues to be on.  It never shows "Radio Connected."  I have tried with a com port as well as an IP address.

I should also mention my "test remote" is by using a laptop wifi connected to a Verizon Hotspot.  Since the laptrop connects to the Flex without issue I don't think the double NAT issue comes into play.

Bob
K6MBY
Sequim, WA
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Did you log in to your SmartLink account on the CAT application?  CAT and SmartSDR for Windows are independent SmartLink enabled apps and you have to log in to each to use both.

And since you are using the same laptop for LAN and SmartLink connections, make sure CAT is not trying to the radio via the LAN connection (IP address) because it is configured to auto login to the last connection type (this is a new feature of CAT)
(Edited)
Photo of K6MBY

K6MBY

  • 23 Posts
  • 0 Reply Likes
Tim,

Time to hit the manual!  "Log into the CAT application."  So far it is not obvious how to do that.     The LAN connection is unplugged.

Bob
Photo of K6MBY

K6MBY

  • 23 Posts
  • 0 Reply Likes
Well it helps to have the most current manual too...  Found it and now the CAT dialog shows "radio connected."

Answer is to click on the "radio not connected" and a SDRCat login will appear.

Bob
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
:-)