SSDR V2.0 IOS Needs Restore Constantly

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
In using V 2.0 of SmartSDR on IOS, I have found that it asks to be restored about once every two to three times.  I do it and it works. But I wanted to let someone know. This happens on my iPhone 7s and iPad Pro. Sometimes it just escapes the application and I have to press on the app again, restore  and then proceed. My radio is a FlexRadio 6300. 
Photo of N2LRB

N2LRB

  • 24 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Tony Taddeo

Tony Taddeo

  • 67 Posts
  • 29 Reply Likes
I also have the same problem with the latest version of SmartSDR for IOS unregistering itself on a regular basis and requiring a restore to provided the purchased Flex Radio access feature. I am running IOS 10.3.3. Thank you.
Photo of Burch - K4QXX

Burch - K4QXX

  • 535 Posts
  • 132 Reply Likes
I am also having this issue.
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 151 Posts
  • 40 Reply Likes
Official Response
Can you guys please try to delete the App from your device, re-install from the App store and let me know if the problem still persists.

Thank you!

73,
Marcus, DL8MRE
(Edited)
Photo of N2LRB

N2LRB

  • 24 Posts
  • 0 Reply Likes
Marcus,
This did not occur to me yesterday at all.  I started disconnecting from the radio using the "Disc" on the app as oppose to shutting down the app by pressing the home button and swiping the app up.
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 151 Posts
  • 40 Reply Likes
Ok, thanks Jose, seems to be (hopefully) resolved.

Unless somebody else would disagree.

73,
Marcus, DL8MRE
Photo of Larry - W8LLL

Larry - W8LLL

  • 531 Posts
  • 115 Reply Likes
I am noticing no persistance after a disconnect and reconnect, keeps defaulting back to a 20 meter cw frequency. Anyone have this issue, two differant ios devices doing the same thing here.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
I can confirm this, with additional information.
If I change frequency to another frequency or mode on 20 meters, then it remembers that frequency and mode.

But if I change to another band, then it returns to 20 meters after I disconnect and re-connect.

It doesn't matter if I close from the iPad and open on the iPhone, or use the same device.

Ken - NM9P
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
I only had the "restore problem" two or three times on the first day after upgrading the iOS app. It hasn't done it since.

I wonder if it was because my iPhone and iPad had not gotten synced together yet? I remember that I was switching back and forth between the two and playing around quite a bit.

I just tested again with the iPad, and disabled SmartLink, closed and reopened the program, connected via LAN, reactivated SmartLink & logged in, and connected via Smartlink.

All was OK.

Ken - NM9P
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Btw, it didn't seem to matter if I hit "disc" (which is my normal method of disconnecting) or unceremonially dumped it with the "Home + swipe" method.

I still recommend disconnecting correctly first.