SSDR v1.10 Beta Flex Control anomaly

  • 1
  • Problem
  • Updated 3 years ago
Since upgrading to v1.10 Beta, I've been experiencing an anomaly with my Flex Control.  About once a day, the Flex Control will stop working, requiring a shutdown of SSDR and a reboot of the Win10 computer.  The knob is setup on COM99, and otherwise works fine.  When the lockup occurs, the mouse wheel continues to function, and looking at Device Driver, no obvious problems are shown.  I have a second Flex Control on order to pair with the first using SDR-Bridge to control the 2nd knob.  It will be interesting to see if the same problem occurs with that knob.
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 599 Posts
  • 130 Reply Likes

Posted 3 years ago

  • 1
Photo of Al K0VM

Al K0VM, Elmer

  • 608 Posts
  • 102 Reply Likes
Rick,
     I stopped having problems with my comports when I assigend the Flex Knob to a low numbered comport  ( COM 4) and assigned the SSDRCAT ports above that ( COM5, COM6, etc.) 

FWIW.. My Com1 is a HW MB port,  COM2-3 are USB serial ports, COM4 is FLex Knob, COM 5-7 are SSDR CAT ports, Com 8-9 are VSPE ports, COM 10-12 are USB serial ports, and COM 13-17 are more SSDR CAT ports..  This has all been stable through several SSDR and Windows updates.

Caveats-- DDUtil load is defered for about 60 seconds after PC boot, all USB serial ports are FTDI, and moving a USB-serial device to a different USB port may result in its comport number being reassigned.

YMMV

AL, K0VM
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 599 Posts
  • 130 Reply Likes
Al,
All of my comports from 1-75 are shown in use when I try to select a lower one, but using all the "show hidden devices" tricks I'm unable to find a way to delete them.  Except for the expected COM1 & COM3 (probably keyboard & mouse), Flex VSP port pairs 4-6&104-106, the ERC Rotor control on COM30 and the FlexControl on 99, nothing else shows...nothing grayed out.  Any ideas how I can free the rest up?

Rick, W0FG