SSDR CAT gone nuts

  • 1
  • Problem
  • Updated 4 years ago
I have 8 physical serial ports on my computer. Also, I am using a USB 2.0 port assigned to COM 16 to connect to AlfaSpid rotator controller via USB. Flex Control is assigned to COM 40. So, COM 16 and COM 40 are the Foreign Virtual Ports.

SSDR CAT has gone wobbly today. I normally have a Flex virtual serial port Shared pair COM 9-19 and I connect logging programs to COM 9 without any problems - usually, but its now suddently broken.

COM 9-19 pair has disappeared from SSDR CAT Available Flex Serial Ports even though COM 9 still appears in "Connect 3rd Party Program To Port" and COM9 appears on the Port Map.

N1MM Logger+, which had been working OK, will not connect to COM9. If I set up a second Shared Flex Port at COM 10-20, Logger+ won't connect to iCOM10, either.

No amount of Delete All Virtual Ports and rebooting and setting up new ports fixes the problem.

Suggestions?



Photo of William Hein

William Hein

  • 93 Posts
  • 10 Reply Likes

Posted 4 years ago

  • 1
Photo of William Hein

William Hein

  • 93 Posts
  • 10 Reply Likes
I meant dedicated ports above, not shared
Photo of William Hein

William Hein

  • 93 Posts
  • 10 Reply Likes
I decided to try this one last time:

deleted all the Virtual Ports

power cycled Flex 6700

rebooted computer

created new COM 10-20 PPT DTS/RTS pair in SSDR CAT

connected N1MM Logger to COM9 (CAT) and COM10 (PTT)

seems to be working now, no idea why N1MM wouldn't connect to COM9 for last hour.

I didn't mention it before, but I was getting frequent "Can't create new port, please quite SSDR CAT" (I'm paraphrasing) while trying to fix this.

Fingers crossed

Bill AA7XT
Photo of William Hein

William Hein

  • 93 Posts
  • 10 Reply Likes
I am trying to remember if COM9-19 every should have appeared in the Available Virtual Ports list?
Photo of KM4CQG

KM4CQG

  • 222 Posts
  • 34 Reply Likes
William

I have had this exact problem in the past. The only way i could fix it was to uninstall all my Flex software 3 programs then re-install it. If Cat was a stand alone install it would be easier but it's not.

I worked for a few days trying to resolve it until I finally removed and re-installed and all was fixed.

Sorry
Ian