SSDR and 6400 - public firewall setting on v1803

  • 1
  • Question
  • Updated 3 months ago
  • Answered
This may be old news to some but this morning SSDR (.33) was not seeing my 6400; it was fine last night.   Earlier I made some changes in the sharing setting to network to printers, but I do not recall touching the firewall settings though advanced sharing does have a Public settings section. Sharing in the Public profile has printers and files, and network discovery are off.
After ten minutes of "oh no!" I turned off all firewalls (Domain, Private, Public) and voila the 6400 was connected. Then turned each back on in sequence and found the Public firewall when turned on disconnected the 6400. 
The solution was in the "allow an app thru the firewall" setting.  SSDR shows up twice in the list, probably as intended, but the box for public was not checked.  I checked the box, turned on the Public firewall and the 6400 remained connected.  This option does pop up during a new install of SSDR - private is allowed, public is not, apparently by default.
Paragraph 37.1.2 gave me a clue regarding the firewall though it does not mention the Public firewall.  My default is to never allow an app thru the public firewall on a computer; inbound or outbound without good reason. 
The 6400 is direct connected to the computer with SSDR.
Why would I need SSDR as an allowed app through the Public firewall for the 6400 to direct connect to SSDR? This is W10 v1803.  I do not recall this issue in v1709.

This is probably a case of, "did you touch it??" but nevertheless I got bit.
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 128 Posts
  • 23 Reply Likes

Posted 3 months ago

  • 1
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
Is the radio on the local network?  If so, it sounds like your local home network has been switched to a public network.  Otherwise, that shouldn't affect it.

Unless you're using SmartLink and it's not on the local network.
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 128 Posts
  • 23 Reply Likes
Yeah, it was and is on a private network-direct to the PC via ethernet cable.  When I first looked at the firewall all three were on, the firewall on public was the issue.  The radio is showing a 169.254.x.x IP and 255.255.0.0 mask.  The ethernet adapter is on the same subnet. 

Its working fine but I had to allow SSDR thru the public firewall.  I don't know why. 

It could be MS trying to "help" me.  Or, I have something set wrong in my network.
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
Just an FYI.  A 169.254.x.x address is usually assigned to a windows machine that fails to obtains an ip address from a DHCP server.   

ie, there is a problem with the radio obtaining an ip address from your DHCP server. 
Photo of AA0KM

AA0KM

  • 324 Posts
  • 56 Reply Likes

I have had a couple of computers  over the last couple years with updates change with windows 10 updates to Public firewall.

Click on which one you want/need and change and reboot.

My network is fiber to the home FTTH  so I think windows thinks its extended public.


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3462 Reply Likes
Windows or something else changed your active Network Location from private to public.  This had nothing to do with SmartSDR.  We configure the firewall setting to only allow access through the firewall when the Network Location is Private - the correct setting for your local LAN.  

This is shown by the setting AA0KM has shown above.
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 128 Posts
  • 23 Reply Likes
I didn’t believe this to be SSDR: all was fine until 1803. I have seen several unexpected changes in settings upon v1803 upgrading. In particular, the share settings between two PC’s in the same workgroup became an issue, as in, stopped working. I think the behavior of the public network profile and it’s firewall is an indication that my network settings are incorrect, a general problem rather than SSDR specific. Still, the seemingly sudden failure to find the radio can be baffling, but, the learning experience is useful, and maybe even fun.

All of the info in this thread is helpful. Appreciated.