SSDR 1.8 broke Maestro

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
I installed SSDR 1.8 on my computer and no problems.  Radio works as it should.  Then I turned on Maestro and tried to update.  It looked like it was updating fine but at the end it said Waiting On Hardware Initialization (W).  I waited for about 10 minutes and nothing happened.  I turned off Maestro and turned it back on and instead of getting the nice graphical Maestro screen, I get a blue screen that just says Maestro in text.  Then, I get a black screen with a grey window that says "Waiting on Hardware Initialization (W)".  I don't get prompted to select a radio.  Any ideas?
Photo of Burch - K4QXX

Burch - K4QXX

  • 449 Posts
  • 100 Reply Likes

Posted 3 years ago

  • 1
Photo of David Warnberg

David Warnberg

  • 570 Posts
  • 62 Reply Likes
can you factory reset a maestro and start over?  I don't know I do not have one.

David
Photo of Burch - K4QXX

Burch - K4QXX

  • 449 Posts
  • 100 Reply Likes
I don't know how to factory reset.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 494 Posts
  • 173 Reply Likes
Try rebooting your radio and see if that helps.

73
Photo of Cal Spreitzer

Cal Spreitzer

  • 383 Posts
  • 77 Reply Likes
I had the exact same issue with my Maestro.  You will need to submit a support ticket to Flex for resolution.   I've been unable to get the error to clear.  Your the 5th Maestro that's reported this issue today here on the forum.

Cal/N3CAL
(Edited)
Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 535 Posts
  • 212 Reply Likes
My Maestro is also down with the "Waiting on Hardware Initialization (W)".  Hope to get some insight on how to fix or instructions to covert to a trouble ticket.

I have a 6300.  I have rebooted and hard reset my 6300.  This did not clear the problem.
Photo of Jim Runge

Jim Runge

  • 91 Posts
  • 18 Reply Likes
Don't do a radio reset.  That will not fix the problem.  Flex is aware of the problem and working on a fix.  Until they notify us just put the Maestro aside.
Photo of Marv

Marv

  • 54 Posts
  • 1 Reply Like

Perhaps I am wrong but I thought this was a release for the Maestro and not your computer.  Any way my upgrade to the Maestro was flawless.

Marv W0ZK


Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 535 Posts
  • 212 Reply Likes
There is also a SmartSDR Windows upgrade involved.  This process also upgrades the software in the Radio.  This portion of the upgrade went well.  It is only the Maestro portion of my upgrade that went south.
Photo of Burch - K4QXX

Burch - K4QXX

  • 449 Posts
  • 100 Reply Likes
Same here, radio and computer are fine.  Just Maestro messed up.
Photo of k3Tim

k3Tim

  • 880 Posts
  • 176 Reply Likes
Sorry to hear some of the devices are having a problem.

I had no problems updating but did PC update; updating the radio then rebooted the 6500 and then updated the Maestro. It was an attempt to have the radio f/w updated via the PC. In addition the Maestro was on 12V-DC power.

Did this procedure also result in a Maestro glitch?

k3Tim
Photo of Lewis Cheek

Lewis Cheek

  • 239 Posts
  • 41 Reply Likes
I hate to say anything, might result in a curse, but no issues here. Now if storms will move out of low country of South Carolina I'll give it a test run. :)

Lew N4CO
Photo of Ray - K6LJ

Ray - K6LJ

  • 46 Posts
  • 14 Reply Likes

I started this morning by turning on the 6700. Then when I started Maestro I saw the 1.8 update. I installed 1.8 and it looked like it also updated the radio. As long as I was on the Maestro it appeared to work well. This evening after shutting down the Maestro and starting the computer sdr it proceeded to revert to the earlier version. When the Maestro update first showed up I looked and could not see a computer update for 1.8. This evening I download and installed the 1.8 on the computer first, Then started Maestro. When it asked to upgrade it took only a second or two and started up fine. Both seem to be working fine now. I did notice that I received the HW init error but remembered that I did not turn on the 12v supply before starting up. Maybe this is what happens when people say they have the hardware init issue. either their battery is low or 12v supply is disconnected. Even if both are disconnected the internal batt will attempt to start Maestro but it always for me results in the hw init screen. Love my Flex

Update - after powering on Maestro and doing the upgrade I went back and started the computer sdr. again it rolled back the software to the earlier version. i'm going back to 1.7 until things get corrected

(Edited)
Photo of k3Tim

k3Tim

  • 880 Posts
  • 176 Reply Likes
You need to install the Smart SDR 1.8 on your PC also. The download is at the FRS website.
Photo of Ray - K6LJ

Ray - K6LJ

  • 46 Posts
  • 14 Reply Likes
I did - however what I just found out was after installing 1.8 on my  computer I failed to look for the new 1.8 icon. Of course then radio is going to return the radio to the earlier release when I select the 1.7 version. I have tried both the radio and my maestro now and I must have been lucky. Both are working with 1.8.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9154 Posts
  • 3507 Reply Likes
Official Response
I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.