SmartSDR.XML file

  • 2
  • Question
  • Updated 4 years ago

Tim: 

This is a question about using 3rd Party Software with my FLEX 6500.  Everytime I start the Fldigi application, I have to open the Fldigi RIG configuration window, load and initialize the SmartSDR.xml file. If this file is not loaded and initiated, DAX will not work with Fldigi. I have saved the Fldigi configuration when shutting down the application. However, I  must repeat the SmartSDR.xml load and initialization process with each restart of Fldigi.

 Is there some way that this SmartSDR.xml file can be loaded and initialized with the initial start of Fldigi?  Everything works correctly after this .xml file is loaded and initialized. It is a number of initial steps that could possibly be eliminated.

Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes

Posted 6 years ago

  • 2
Photo of Brian Morgan VK7RR/4

Brian Morgan VK7RR/4

  • 79 Posts
  • 18 Reply Likes
I have the same problem with FLDigi but my solution is to simply uncheck the top box, which means you have to "initialise" again, then re- check it, initialise, save and you are good to go. This way you don't have to reload the XML file.
Photo of Ned K1NJ

Ned K1NJ

  • 317 Posts
  • 83 Reply Likes
    At the bottom of the page where you have been initializing the .XML file,
there is a "save" button.  Initialize, then save.  See if that helps.

Ned, K1NJ
Photo of Brian Morgan VK7RR/4

Brian Morgan VK7RR/4

  • 79 Posts
  • 18 Reply Likes
Ned, the Save button does not help. For some reason FLDigi loses handshaking to SmartCat and needs to be re-initialised.
Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes


Ned K1NJ

 I have used the Fldigi Configuration Save button after resetting the PTT and .xml file. Also, I use the configuration "save" process in the Fldigi configuration Menu. If I do not check the PTT or CAT boxes and restart Fldigi, it still does not work with the FLEX PTT Port or DAX.  I have tried both ways.. When I get everything set, FLEX CAT and PTT work correctly. It is just a hassle to have to reset these settings each time I run Fldigi.

Bill W4EY

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
I have seen this behavior too.  I am trying to determine what is preventing Fldigi from initializing properly.  This looks to be Fldigi specific as other CAT enabled third-party apps are not showing this behavior.
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
Make sure the SmartSDR.xml file is located in the \Users\<name>\fldigi.files\rigs directory.  What I have found is when I startup fldigi the CAT doesn't usually work also indicated by the greyed out QSY button so I go into configure\rig\RigCat and do an initialize.  Once I do this the QSY button down at the bottom right of the fldigi screen is no longer greyed out indicating CAT is working.  This assumes you are using RigCAT and not Hamlib.

I have not had any DAX issues with fldigi.
Photo of Mike Sonn

Mike Sonn

  • 46 Posts
  • 5 Reply Likes
I know this thread is old, but I'm just starting the 6300 adventure after using PSDR for the last 5 years.

In the "PHNE" block on the right side of SmartSDR, I needed to select "+ACC" and "DAX" to make FLDIGI work for all modes.