SmartSDR v1.2.1.49 hangs

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
I'm running SmartSDR v1.2.1.49 on my 6500 and have started having trouble since the update. The environment is a virtualized Win7 32 with 4gb ram and four core running under ESXi 4.1.  My setup includes DDutil, SmartCAT, and DAX feeding 6 instances of fldigi (two per each of three DAX channels).  Slices B, C, and D are controlled by DDutil's RCP re-direct feature (and some custom scanning software).  The remaining slice is used for making contacts with manual control via DM780.  All this puts my cpu load between 25% and 40% but usually the lower of the two. 

Prior to the update I could leave this running for days without any problems.  Now, I might make it through a day before SmartSDR hangs. Though, it's likely it's the 6500 itself that's hung. The only way to get it going again is to long-press the power button.  Restarting SmartSDR doesnt do it. A simple press of the power button has no effect.  One of the times this happened, shutting down SmartSDR and waiting a bit (well hours) resulting in the 6500 being available again.  Mostly though, I have to put my hands on the 6500 and long press that button.

When I'm away from the rig I leave all of this running just collecting spots.  I've tried stopping DM780 when I'm not around to see if that would help.  It didnt. I have not tried (with 1.2.1.49) simply leaving the 6500 and SmartSDR running for days to see if it would hang.  

If this has been reported before, great.  If not, let me know what other information I can provide. 
Photo of K1DBO

K1DBO

  • 290 Posts
  • 40 Reply Likes

Posted 4 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3412 Reply Likes
Official Response
I have entered this report as a defect in the developer's bug tracker for additional investigation.  Thanks for the report.