SmartSDR V2 and WSJTx setup video

  • 6
  • Idea
  • Updated 6 months ago
  • Implemented
  • (Edited)
All

This video was just uploaded to help with the initial setup of WSJTx V1.9 and SmartSDR V2.


  


Mike va3mw
Photo of Michael Walker

Michael Walker, Employee

  • 366 Posts
  • 96 Reply Likes

Posted 6 months ago

  • 6
Photo of Buck Rogers

Buck Rogers

  • 3 Posts
  • 1 Reply Like
Well done Mike, many thanks for taking the time to put this together. K4IU 
(Edited)
Photo of Chris DL5NAM

Chris DL5NAM

  • 597 Posts
  • 130 Reply Likes
Mike what SSDR version you using in video?
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2270 Posts
  • 904 Reply Likes
Looks like 2.3 Alpha, which was shown at Dayton.
Photo of KC2QMA_John

KC2QMA_John

  • 559 Posts
  • 193 Reply Likes
Did anyone record the talk at Dayton? I could not make it this year.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2270 Posts
  • 904 Reply Likes
Which one? The banquets? I don't think so. You should attend next year. It's very nice to meet up with the folks. 
Photo of Jim Gilliam

Jim Gilliam

  • 861 Posts
  • 184 Reply Likes

Thank you so much for the wonderful information. All this time I have been saying that this program would not work with 6.xxx as the selected radio. I was wrong!

I had one slight hitch. When I selected Flex 6.xxx my network server entry had no defaults showing. I had to manually enter the I/P address of my computer after doing a network scan of the clients. It still failed when I selected 192.1.168.131:5002. I am not using DDUTIL. However once I added 5003 as an additional CAT port it worked perfectly. Thank you for going to all that trouble. Well done!


Jim, K6QE

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
Mike, thanks so much for the excellent video.  I had my FT8 set up using VOX instead of PTT because I couldn't make PTT work with the old WSJT-X version.  Your video cured that.  As per your suggestion, I downloaded the latest version of WSJT-X 1.9.1.  I should note that I did not download the latest version of JTAlert-X, still everything worked properly, including automatically logging to HDR,  except I kept getting a pop up "Cat server Send error". The error pointed to DDUTIL. On a lark, I updated to the latest version of JTAlert-X version 2.11.3 and the CAT error message went away. So I would recommend that everyone update both WSJT-X and JTAlert-X at the same time. Many tanks.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2270 Posts
  • 904 Reply Likes
For what it’s worth - you don’t need to add an extra port for PTT, although it certainly doesn’t hurt. You can do PTT via CAT command and it works fine.
Photo of Roger J. Buffington

Roger J. Buffington

  • 148 Posts
  • 27 Reply Likes
That makes sense.  
Photo of KC2QMA_John

KC2QMA_John

  • 559 Posts
  • 193 Reply Likes

I was just wondering if anyone video recorded any of the Banquets? I plan on making it next year but would love to see and hear what I missed this year.

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2270 Posts
  • 904 Reply Likes
It wasn’t recorded. You missed out!

They did unveil zoom to band and spots in the panadapter. Gerald also gave a history lesson on flex
Photo of KC2QMA_John

KC2QMA_John

  • 559 Posts
  • 193 Reply Likes
WOW Zoom & Spots!!! Can't Wait!
Photo of N9VC

N9VC

  • 125 Posts
  • 34 Reply Likes
Hi,

Just a note for anyone who encountered what I did
when I upgraded from 1.8 to 1.9.
My drop-down window for choosing the different bands
were blank. If I chose a band manually, it would show
the band in the drop-down window and the freq in the
in the dial frequency window.
I uninstalled and re-installed several times. Downgrade
to 1.8 and the band choices were back. The only fix
I found was not only, uninstall, but go into the users
folder on Windows and remove WSJT from there also.
I re-installed WSJT 1.9 and, presto, all functions
were there.
Not sure if I am the only one who encountered this,
but this is what worked for me.

73, Jim N9VC
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 129 Posts
  • 40 Reply Likes
Go to wsjt-x Settings / Frequencies, then right click on the frequency list and chooes "Reset" from the context menu, et voila, all the default frequencies will [re]appear.
Photo of N9VC

N9VC

  • 125 Posts
  • 34 Reply Likes
Thanks,Ted. I wish I had known that, would have saved the rut in the side of my head.
73, Jim N9VC
Photo of Roger J. Buffington

Roger J. Buffington

  • 148 Posts
  • 27 Reply Likes
Wonderful video, OM.  With a few collywobbles, it got my WSJT-X set up, although I haven't been able to test it much on the air because I did it early in the morning when there were no signals to be had.  To get it going I had to put in "localhost:###,"  not just the number for the network location.  It worked though; passed the PTT test and so forth.  This community sure is chock-ful of helpful folks.  Hope I can be one of them one day.  Thanks again de Roger W6VZV
Photo of Roger J. Buffington

Roger J. Buffington

  • 148 Posts
  • 27 Reply Likes
I did have one question.  On the video, the OM inputs "5003" (I believe it was) for rig control.  When I did it, both when my rig was connected to the computer and later, to the network hub, it would not work for me unless I input "Localhost:5003".  Just the number would not do it for me.  Can anyone explain this?
Photo of Duane  N9DG

Duane N9DG

  • 77 Posts
  • 24 Reply Likes
The "Network Server:" box in WSJT-X is expecting a TCP IP address and a port number. So port number alone is not sufficient. Using "localhost" will allow the network stack resolve the loopback IP for you. Other people use 127.0.0.1 for the IP address, which also works because it is the loopback adapter IP address for the computer, which is common on all OSes.
(Edited)
Photo of Roger J. Buffington

Roger J. Buffington

  • 148 Posts
  • 27 Reply Likes
Understood.  I was just curious how, in the video, it was that Mike just enters 5503 and it works.  Shouldn't it have been localhost:5503?  Took me half and hour to figure out I needed to add "localhost" LOL.
Photo of Michael Walker

Michael Walker, Employee

  • 362 Posts
  • 96 Reply Likes
Deep under the cover in Windows (and all operating systems) there is a file called 'hosts'.    http://www.thewindowsclub.com/hosts-file-in-windows  When your operating system needs to take a name and find the IP address, it looks at the hosts file first and then it goes to the Domain Name Servers you have set up for your Network card.   

You can test this by bringing up a command prompt and doing an

nslookup localhost

C:\Users\840G1>nslookup localhost

Server:  UnKnown
Address:  10.2.0.10

Non-authoritative answer:
Name:    localhost.homeip.net
Address:  127.0.0.1



In that file will be a lookup table that says the localhost is the same as 127.0.0.1.   127.0.0.1 is the default IP address for the actual 'host' or the computer you are working on.

You can actually add your own names if you wish to the hosts file.  You could say my computer name is "fredflinstone 127.0.0.1" and get the same result.  

The structure for this entry can be either:

127.0.0.1:5003 

or

localhost:5003

Where it is "ip address" or "host name" : port number

The Colon is critical too.

There are many ways to solve this.  I tried to give you the most fool proof one.


Mike 
Photo of Cal Spreitzer

Cal Spreitzer

  • 352 Posts
  • 64 Reply Likes
Great Video Mike!  May I add you should open up your TX filter "Low" and "High" cut to allow you to tx anywhere within your selected receive bandwidth. 

Cal/N3CAL
Photo of Dave - W6OVP

Dave - W6OVP

  • 221 Posts
  • 69 Reply Likes
TNX for the video Mike. The more of them the better. They really do meet a need.
In the future please post (or repost) them in higher resolution. On this conventional desktop (at least) it is very hard to read the details of the small images. When I try to go full screen I get FULL SCREEN IS UNAVAILABLE trying several different browers.  -Dave.
Photo of Michael Walker

Michael Walker, Employee

  • 366 Posts
  • 96 Reply Likes
Hi Dave

I have to consider all users, so it is done in 720P exactly.  1280 x 720.  

Not everyone has the higher resolutions.  If you go to the actual youtube video, you can see it full screen.  Just click the YouTube symbole



Mike
(Edited)
Photo of Dave - W6OVP

Dave - W6OVP

  • 221 Posts
  • 69 Reply Likes
If you go to the actual youtube video, you can see it full screen.  Just click the YouTube symbole
Great! I learned something new today...