SmartSDR not starting everytime

  • 1
  • Problem
  • Updated 3 years ago
I am new to flex and have had my 6300 for roughly a week. When I boot it up and get the green light. I start smartSDR and it see's the flex....I highlight that and click connect and the software says "not responding", so I force a close on smartSDR, reboot the radio and hit connect and it works. If i don't use for a prolonged time, I have this happen always on the first boot....always fires up after reboot.
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

Sounds like a network glitch. Does you I/P address show that you are connected to the network? There should be a valid I/P address listed next to the IP Address label under the Radio tab. Make sure the I/P address is correct within the allowable limits of your router.


Jim

Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Sounds like a networking problem.  Are you connecting via a router or directly to the radio ?
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
Radio is connected with Ethernet from the back of the flex to my router
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
This is the screen before the reboot...if I click connect now it wont.....
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

I would expect to see an I/P address like 192.168.1.116, it appears to be a network  I/P address not an internal LAN address.


Jim

(Edited)
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Luke I believe that 169.254.4.126 is a default ip address that windows creates when it can't get a valid address.  What is the subnet address of your network ?  What is the IP of your workstation ?
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
this worked....

Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
Not sure why it takes 2 boots to pull the IP
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes
When it does work, what I/P address is shown ?
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
this is the reboot if i hit connect on this it works
Photo of Jim Gilliam

Jim Gilliam

  • 462 Posts
  • 71 Reply Likes

Well, at least you know what to look for when you turn on your radio. If you don't see the 192.1.66.xx , then you to know to do a power recycle before trying to connect. If I were you, I would leave the radio on and reboot the router. Maybe it will "teach" the router.


Jim

Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
when i turn it off...come back tomorrow and reboot it wont work the first time.....
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
I had this problem early on when my router was not providing dhcp addresses correctly. Be sure and check the ethernet cable from radio and maybe even change it. Also make sure you are getting Link lights on your router.

This sounds like a networking issue where the flex can't get an ip address.  I believe I have heard others with the same problem and its possible a timing issue with flex networking interface. But honestly because its not affecting others I suspect its cabling or router.
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 644 Reply Likes
That other address is more than likely the cable modem / Fios IP. 10. and 192. are the non-routeable domains. It certainly needs to be on the precise subnet, i.e. 192.168.0/1 as the PC or laptop.
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Luke if you do a Google search for DHCP timeout you will see a lot of people have problems with their servers/routers etc taking a long time to issue an IP address. There are a number of reasons for this but the bottom line is the second time you reboot the router probably still has the Flex's ethernet MAC address in its memory. This means it doesn't have to search the network for the hardware, it just issues an ip to that MAC address.

It's complicated but basically the router is timing out before it can determine the physical address of the Flex.

It would take some spelunking into your router and don't know if you are a network guy or not but if you can look up the MAC address for the flex, some routers let you assign an IP to that MAC address. That way there would be no delay and your Flex would get the sam IP ever time.

(Edited)
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
So this gets a little complicated.....the flex is twice removed from the time warner modem. The flex is upstairs and the modem is one floor down. On the modem is a net gear wireless router. In the ham shack I have a netgear extender. It looks like a wifi router and connects to the router below but allows me to plug into the back. The flex is plugged into the back of that (if that makes sense) the signal is strong and never any choppy audio or lag.
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Luke that makes sense and could certainly cause the delay in the Flex being issued an IP address right away.

What model Netgear router are you using ?

See if this link makes any sense to you. It demonstrates how to assign an IP address to a physical MAC address. I think this would solve your problem.

http://kb.netgear.com/app/answers/detail/a_id/25722/~/how-do-i-reserve-an-ip-address-on-my-netgear-r...
Photo of N7AIG

N7AIG

  • 147 Posts
  • 17 Reply Likes

Sounds remotely similar to a problem I had for quite some time, where I constantly had to go in and futz with the network settings after every boot to get the connections going for me. I did a search and found this: (it worked for me... maybe for you too. Nice little Windows esoterica...)

I found this on another website and it worked for me:

"When more than one network connection is available, Windows uses the one with the lowest metric value. By default, it automatically assigns a metric value based on the network connection's rated speed. See An explanation of the Automatic Metric feature for Internet Protocol routes .

To force Windows to use a specific network connection, assign a metric value to each one, giving the lowest value to the desired connection:

  1. Open the Network Connections folder (Start > Run > ncpa.cpl)
  2. Right click the desired connection.
  3. Click Properties > Internet Protocol Version 4.
  4. Click Properties > Advanced.
  5. Un-check "Automatic metric".
  6. Enter a number between 1 and 9999 for the "Interface metric"."
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3642 Posts
  • 1473 Reply Likes
Or better yet

Logon to your router

Set the router to issue a FIXED IP Address to the MAC Address for your 6300

That way it will bypass DHCP and always start up at the same address..

I can guarantee that will solve your problem forever
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
how do I find the MAC of the flex
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3642 Posts
  • 1473 Reply Likes
(Edited)
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Howard you are repeating every thing I have already posted including this link.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3642 Posts
  • 1473 Reply Likes
Lee

Great minds think alike... I am just slower than you are...
Photo of Luke Reynolds

Luke Reynolds

  • 57 Posts
  • 2 Reply Likes
Its not showing the name flex...so trying to figure out which one it is

Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3642 Posts
  • 1473 Reply Likes
From the Flex startup it looks like it should be 193.168.1.29?
Photo of Lee - N2LEE

Lee - N2LEE

  • 275 Posts
  • 143 Reply Likes
Luke,

Go into the terminal / CMD mode on Windows

1. Ping the IP address of the Flex radio (ping 192.168.1.29)
2. Enter arp -a

This will show the MAC address associated with that IP