SmartSDR IOS Speech Processor Issue?

  • 1
  • Question
  • Updated 7 months ago
I installed the SmartSDR IOS on my new iPad Pro 12.9 last night to use with my Flex 6500.  I have tested several times with friends since then, and the audio quality is very poor compared with what it is using my MacBook Pro with Parallels.  In both cases I have used the Equalizer to suppress the bass frequencies, somewhat.

I have not discovered how to record and play back my voice using the iPad, so I have had to resort to using 1 watt and turning down the RF Gain on another radio.  If anyone knows how to record and play back using the iPad I would like to know how to do it.

When I have the speech processor in the Normal mode it appears that I have an abnormally high amount of compression and my voice sounds distorted.  This is with the Mic Bias and Booster turned off on the iPad and the Mic Gain set at about 50.  In both cases I am using the earbuds with mic that come with the iPhone that I have.

With the speech processor off my voice sounds fairly normal.  DX and DX+ are not usable.  All of these settings seem to work fine on my MacBook Pro.

Any suggestions would be welcome.
Photo of Alan - KA4B

Alan - KA4B

  • 111 Posts
  • 11 Reply Likes

Posted 7 months ago

  • 1
Photo of KF4HR

KF4HR

  • 527 Posts
  • 149 Reply Likes
I've had very good reports when using a Logitech H800 Bluetooth Headset with my iPad.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4015 Posts
  • 1241 Reply Likes
I have found that merely keeping it "out of the red" on the IOS app still gives far too much Mic gain. 

I would recommend turning the Mic level down so that your Mic meter only peaks to about 60-70 percent, or so your compression never goes above about 50 percent when using DX or DX+ on PROC.  Set it for even less compression when using NORM.  (remember that the Compression meter shoots from the right to the left.  the further to the left it goes, the more compression you have)

If you will test this, I think you will find that the audio drive is not excessive any more.  It is possible to get very good audio from the IOS app, but you really must watch the Mic gain carefully. 

Ken - NM9P
Photo of Alan - KA4B

Alan - KA4B

  • 111 Posts
  • 11 Reply Likes
Ken, to get my compression level down to a reasonable level in the Normal mode I have to set my mic gain down to 1 or 2%.  Something certainly appears to be amiss here.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4015 Posts
  • 1241 Reply Likes
When you do that are you talking about the gain slider, or the number on the Mic Level meter?  If it is the slider, then you need to go into Settings>Audio>Microphone Volume Adjustment.  You may have it set too high in the settings part of the IOS app.
Photo of Alan - KA4B

Alan - KA4B

  • 111 Posts
  • 11 Reply Likes
Ken,  I wasn't aware of that setting.  With the volume adjustment all the way down to -4 I still have to have the mike gain slider at about 30 percent, which means my level is down about -30 db in order to keep my compression from being excessive.  Isn't that going to negatively affect my signal strength?
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4015 Posts
  • 1241 Reply Likes
If you are showing compression, the rig is already being driven to full power. Beyond that simply brings up the average power. Too much and there will be distortion. I never let compression show more than 50-60 percent on the IOS ap, regardless what Mic gain I need to set to keep it there.

I DO adjust the internal “pre-gain” to that I can keep my regular Mic gain slider between about 50-80.
Photo of Alan - KA4B

Alan - KA4B

  • 111 Posts
  • 11 Reply Likes
Ken, in my case the 'pre-gain' is all the way down and I can't have the Mic gain over about 30 and that makes the Mic Level meter show about -30 dB.  Then I have to talk loud or my power is low.  Even when maxed out the power is usually hitting about 80 watts.
(Edited)