smartsdr ios microphone difficulty

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Can't get iPad 2 Air microphone working with SmartSDR iOS.  The PTT works fine and I can tune and get power out.  I used the iOS default profile and can't get the microphone to work. I've also check the settings on the iPad under "privacy and microphone the SmartSDR iOS is in the "on" position.  Any ideas???
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Make sure DAX is off on the transmit section. That is the problem I had.

Mike va3mw
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Mike,

The DAX is off in the transmit section.  Did you configure anything when you first selectdc the iOS default profile for the microphone?

Much thanks,
Rick
Photo of Barry J Cohen

Barry J Cohen

  • 33 Posts
  • 1 Reply Like

I had to put the iPad and iPhone 6SP profile for TX to *Remote and it worked fine**

I played with it for a while as well till I got it to work with REMOTE

N2BJ Barry

Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Thanks Barry!
Photo of Barry J Cohen

Barry J Cohen

  • 33 Posts
  • 1 Reply Like
Did that work for you?
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Barry,  I got it working from an earlier post and it was my error because I hadn't changed the "mic" to "iPad".  Much thanks!  Rick
Photo of WW1SS - Steve

WW1SS - Steve

  • 755 Posts
  • 259 Reply Likes
Click the actual mic button on the right menu and set it to ipad.
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Steve,

The only reference to the iPad is the "iOS default profile" and there is no "iPad" setting.  Am I missing something?

Rick
Photo of WW1SS - Steve

WW1SS - Steve

  • 755 Posts
  • 259 Reply Likes
Press button in upper right corner to bring up right side menu. Right under the compression meter is a button labeled mic. Press it and select Ipad
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Right Menu, P/CW and above the PROC button. I missed a few times as well.
Mike va3mw
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Mike and Steve, 

That was exactly the setting that I was missing!  I have it set properly and it keys nicely.  However, even with the iPad microphone setting and compression at maximum, I can barely get the meter half way into the green!  Any ideas for this problem?

Rick
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
That is interesting. I have to dial mine back to about 60%. Make sure you have the IOS profiles still set. What happens if you use an ipad headset?

Mike va3mw
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Mike, 

I never did anything with the iOS profiles and didn't know that this was necessary. Please walk me through them.  Also, I don't have an iPad headset.

Much thanks,
Rick
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Look under RF power, left button, IOS_default_profile (TX tab).

Under P/CW, bottom left, IOS_d.._profile

See if that helps. When done, I have my mic gain set about 70 - beside the iPad button.

The Level should peak normally.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Just for yucks, I am now back on my Maestro but I can now use SSDR for IOS as the control panel. cool stuff.
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Mike,

I have both the TX tab and iPad settings with iOS default profile already and when I get up top of the iPad Air 2 microphone, it's still about 50% scale.  Is there another way to get into this profile in settings?

Rick
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
No idea past this point. What happens when you try to record a voice memo? Is it recorded at full audio?

At this time, I would try an external mic if you can find one. You might have a problem with the internal mic.

Mike
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
I've actually made a few contacts, but 20 meters isn't particularly good right now. Both stations thought the audio was a little low but sounded very clean.  Thanks for all your help and I'll probably pick up a microphone and give that a try!
Photo of Larry - W8LLL

Larry - W8LLL

  • 498 Posts
  • 110 Reply Likes
Do you have the 20 db boost on? my bluetooth mics don't need it but the built in mic and ear phone mic seems to need the boost.
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Larry,

That is exactly what was needed!  It's really hidden in the settings and is under "phone" and not "transmit".  Once I turned it on, the audio was perfect!

Much thanks,
Rick
Photo of Dennis Daniel KM6DF

Dennis Daniel KM6DF

  • 91 Posts
  • 11 Reply Likes
In the documentation it states IPad 3 or higher I also have only IPad 2s and I can not get them to work properly . I dont know if anyone has got their 2s to work if so I would like to know how before I replace an IPad. Mine lock up never got to try to TX yet it locks up before I get there.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Hi Dennis

The iPad 2 won't have enough horse power to handle the SDR data streams. That is why it statues iPad 3, it has a different CPU. Sorry, there is no fix other than upgrading your hardware.

Mike va3mw
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Dennis,

I'm using many generations beyond an iPad 2.  The iPad Air 2 is much more recent than an iPad 3 and that was not the source of the microphone problem.  Good luck with yours...but I have a feeling you'll be upgrading to a newer iPad soon!

Rick
Photo of Dennis Daniel KM6DF

Dennis Daniel KM6DF

  • 91 Posts
  • 11 Reply Likes
I'm sure I will
Photo of Peter K1PGV

Peter K1PGV, Elmer

  • 544 Posts
  • 321 Reply Likes
FWIW, I have the same problem with low mic gain on SSDR for for iOS, using my Mini 4. I have the mic gain slider all the way to 100, and I can barely move the meter past 50% -- makes it really hard to get enough TX power out.

Yes, I'm using the standard profile in the app.

No problem at all with apps like Skype.

Odd, huh?

Peter
K1PGV
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4180 Posts
  • 1332 Reply Likes
In the" flex-6000 settings > radio settings > phone" tab, turn the "mic boost" switch ON. This is the +20 dB boost button. It is required if you are using the iPad/iPhone internal mic.

Then be sure that you have selected "iPad" on the mic selection panel (the right side pull-out menus).

Once you have gotten all of this set up, including mile levels, TX EQ, PROC, etc, them you need to save that profile so you don't need to do it all again.

Eventually, with experience, you will probably have several iPad Mic profiles saved -- for rag chew and DXing, and for internal Mic and Bluetooth Mic. Perhaps even for your car's built-in hands-free system.

Some will need the mic boost, others will not. Each profile may need different EQ and PROCsettings.
(Edited)
Photo of Peter K1PGV

Peter K1PGV, Elmer

  • 544 Posts
  • 321 Reply Likes
AH!  Thank you, Ken.

I forgot that little +20db button.

I'll have a chance to test this later today... but I'm quite confident you nailed it.

Thanks again and best regards,

Peter
K1PGV
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Ken,

You're exactly correct and it did the trick!  Your direction under the "phone" tab is what I kept missing.  I was looking under "transmit".  

Much thanks,
Rick, W1HZ
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 279 Posts
  • 76 Reply Likes
I am having the same problem with the mic volume.  I have "iPad" selected for the mic (ACC+ off, DAX off) and even with the mic slider set to 100% I am only getting half scale on the Level meter.

The "mic boost" setting does not seem to make any difference.  Since this is in the 6700 settings section (along with mic bias), I suspect this is only for the hardware mic inputs actually on the radio, not for remote input, at least that is the way it is acting here.

I have tried both the built-in mic and the earbuds mic on my iPad Pro.  The volume seems fine for other apps.

Is there another boost setting other than the one under the "Flex-6700 settings / Phone" menu?

73, Bob, N7ZO

Also, the "Mon" setting (below the processor)  does not seem to have any effect.
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4180 Posts
  • 1332 Reply Likes
What is your processor setting and PROC meter reading? Are you getting full power output or close?

Have you powered your rig down and back up recently?
I have had a rare couple of times that I needed to do a power cycle to sort things out, especially after changing back and forth between clients rapidly, or experiencing a network dropout at the wrong time.

Btw: the Mon function is not implemented yet, as far as I know. Nor is XVTR selection, DEXP, or FDX.
(Edited)
Photo of W1HZ

W1HZ

  • 15 Posts
  • 0 Reply Likes
Peter,

We'll get it figured out over time.  It's a new app and someone will have a fix.  Meanwhile, I am making contacts with the iPad.

Best,
Rick
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1461 Posts
  • 738 Reply Likes
What I get for not reading the manual. Wasn't intuitive that PTT in the upper bar isn't actually PTT with the actual PTT being a toggled by what first impression was just an indicator.

Laughing at myself on this, but perhaps it could be a bit clearer that the "real PTT" is toggled to show/not-show by the PTT that is on the gray bar?

Of course I could read the manual or watch a video, but I wanted to see if I could muddle through unaided.

73

Steve
K9ZW
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3737 Posts
  • 1600 Reply Likes
FWIW.. none of the iOS products should require u to RTFM.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4202 Posts
  • 1338 Reply Likes
Steve, I was confounded by that the first time I began testing it a few months ago, until I noticed the PTT button toggling on and off as I pressed the PTT on the menu bar!

It was one of those "Oh, Duh!" Experiences. Ha ha.