SmartSDR IOS Connection Error

  • 1
  • Problem
  • Updated 2 weeks ago
  • (Edited)
Trying to connect Iphone to radio through Smart SDR IOS. I check the ports on my home network and all is OK. When I start the APP I get "You are currently not connected tap here to connect" I tap and it will show my radio via smartlink. When I tap on my radio in the list of discovered devices it just goes back to " You are currently not connected. Tap here to connect"

Also if I let it sit after trying to connect I get. . . Smartlink Connect " no response from server"

Any Thoughts??
Photo of KK9W - Steve

KK9W - Steve

  • 496 Posts
  • 164 Reply Likes

Posted 3 weeks ago

  • 1
Photo of KK9W - Steve

KK9W - Steve

  • 496 Posts
  • 164 Reply Likes
Also just noticed if I am running from home and I start the Smart SDR IOS app it will show that it is connected to my computer at home and asks if I want to disconnect or do remote control. It will do neither.
I am on T-Mobile if that helps.
Photo of KK9W - Steve

KK9W - Steve

  • 496 Posts
  • 164 Reply Likes
No one knows what the problem might be with this??
Photo of KK9W - Steve

KK9W - Steve

  • 496 Posts
  • 164 Reply Likes
I can connect using my iphone as a hotspot to my PC but the Iphone app will not connect.
Photo of DJ1YG

DJ1YG

  • 3 Posts
  • 0 Reply Likes
the same happens when I start the Smart SDR IOS app. Validation seems to work correctly and the radio with my name is displayed but when I want to connect I am told that I am currently not connected. Also, as with Steve, testing the smartlink connection directly at the radio results in the green light showing that everything is OK.. Can it be that the recent change of the MAC address causes the problem?
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 139 Posts
  • 40 Reply Likes
This looks like SmartLink is not fully configured (or not working).

To track such issues down, I would recommend to disable LAN ("LAN mode" to off in the App settings) while trying SmartLink. Or vice verse to disable SmartLink ("Enable SmartLink" to off and "LAN mode" to Discover) when trying a local WiFi connection without SmatLink.

This way you don't get confused by these totally different connection types.

Then, I would recommend the following steps:

  • try to use WiFi only with the App - without SmartLink.
  • try SmartSDR for Windows, try the SmartLink test button and see if it is green
  • now, ensure that your iPad/iPhone is not connected to your network via WiFi (e.g. disable WiFi)
  • Start the App, disable LAN (as mentioned before) and try to connect
  • If it you can't connect and it doesn't work, continue as follows:
  • if you see the Radio in the Radio chooser, tap on the (i) Icon
  • Scroll down and locate the TCP Port and UDP Port and compare if these are the same ports you have configured for SmartLink and manually forwarded in your router. If you are using UPnP, there might be different ports and they don't have to be manually forwarded but in no case can these ports be anything equal to or below zero.
  • If these ports don't match or are equal or below to zero, try to setup SmartLink again on your radio, use manual settings and forward the same ports on your router.

A few other findings I had while setting up SmartLink (felt) thousand of times:

  • It was simetimes necessary to power-cycle the Radio when SmartLink Settings have been changed.
  • I had a couple off issues when assigning a fixed IP to the Radio using SmartSDR for Windows and I had to revert back to a DHCP IP and instructed the router to keep always one and the same IP for the MAC Address of the Radio.
  • Before assuming an issue with the iOS App, I would - if possible - always check with SmartSDR for Windows from another network (e.g. ask another HAM to use SmartSDR for Windows to connect to your Radio using SmartLink).
  • And yes, as mentioned, the MAC address issue of the Radio did indeed cause problems. In this case, the router remembers the wrong IP Address of the Radio with the old MAC Address and all assignments are no longer working. So everything needs to be setup again (Router, Smartlink) if this turned out to be the problem.

Please keep us updated.

73,
Marcus, DL8MRE
Photo of DJ1YG

DJ1YG

  • 3 Posts
  • 0 Reply Likes

Hi Marcus,

thanks for the various proposals. I tried them all except only the issue with the fixed IP address (I have been using a fixed address ever since starting v2 and the app worked fine with it) and except the proposed check with SmartSDR for Windows. Each attempt ended with the error message "SmartLinkServer not responding" or sometimes "Such Fehler".

I dont know why but I then tried to connect with the radio turned off (6k7 running v 2.1.33 and the latest version of the app). Same error msg. Thereafter I  re-started the  radio. Error msg appeared for less than a second then disappeared and connection was established!  This happened yesterday. Since then the app connects properly although the error msg continues to appear shortly before disappearing and connecting. Thus, the problem disappeared.

Thank you for the fast and very detailed assistance

vy 73, Dieter DJ1YG