SmartSDR iOS Bluetooth audio disturbances.

  • 1
  • Problem
  • Updated 1 year ago
  • Acknowledged
Hi,

Apologies for yet another question to the forum.

When using SamrtSDR iOS and a  bluetooth headset every time audio is interrupted (for example enabling and disabling audio on a slice or after a PTT event) there is a large increase in audio level after the audio is reinstated. This event last for <1 sec.

The behaviour is only really apparent when just listening to predominantly noise like when listening to a weak signal if listening to a strong signal it is not as obvious if at all.

 Also the effect is different when using two different headsets, with  a BlueParrot VX540 it is very noticeable and you get large bursts of noise even when there are small almost imperceptible audio interruptions (probably a few missed packets of data). With a Logitech it is more just a increase in audio level after a PTT or enabling audio on a slice.

I have conducted a series of tests but have not been able to find the root cause of the problem. As the effect is different on different headsets the headsets seem to be part of the issue and wonder if it is some type of auto audio gain control and one headset is more aggressive than the other.

Not sure if the problem was there before the latest version as I have just acquired the Blue Parrot headset and it makes the headset almost unusable.

I have checked enabling and disabling audio in other apps does not have this effect and all works well it is only in SamrtSDR iOS I have the problem.

Tonight I will conduct a few more tests using the iPad with wired network connection so preventing any packet loss.

Any help would be appreciated.

Any comments Marcus?
Photo of Andy M5ZAP

Andy M5ZAP

  • 161 Posts
  • 35 Reply Likes

Posted 1 year ago

  • 1
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 129 Posts
  • 37 Reply Likes
Official Response
Hi Andy,

thanks. I was able to find the parrot. It's not that expensive here (probably due to the loss of the pound so brexit seem to work for us - hi) but I was indeed now (finally!) able to reproduce at least 1 A.

I always had "Allow Stereo" switched on and once it is on, you don't hear this 2 second long volume increase.

Can you try what happens with your Parrot when you switch "Allow Stereo" to on. Over all volume will decrease when switching this on so you will need to increase the physical volume sliders.

Also, please check if you are able to use the Microphone as one Headset I am using here works well with both settings (even without the 2 second volume increase) but it's Microphone stops working when "Allow Stereo" is switched on.

vy 73,
Marcus, DL8MRE