SmartSDR for Windows has lost connection to the radio. Please reconnect. 1.10.15 Beta

  • 1
  • Problem
  • Updated 2 years ago
I typically use my Maestro with my Flex-6500, but when I use SmartSDR 1.10.15 Beta on a Windows 10 machine I frequently get the error: "SmartSDR for Windows has lost connection to the radio. Please reconnect." I've had this happen 4 times in the last 3 hours this morning. This is actually one reason I use the Maestro a lot is that it is more stable it seems.  

How can I keep this from happening. 

73 Chris AK4SK
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes

Posted 2 years ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 431 Posts
  • 149 Reply Likes
Try connecting a LAN cable directly between the radio and computer. If it works there you have a network device or LAN cable failure. Make sure the LAN on your computer is not set to go to sleep.

Mack
W4AX
Alpha Team
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
Thanks Mack. I did have the LAN setting enabled that allowed the computer to put that to sleep. That is now off but the problem continues to occur. I'm using a switch so that I can connect my Maestro, Flex-6500, and wifi range extender together. When I get home I'll try a direct connection.

73 Chris
(Edited)
Photo of Bill W2PKY

Bill W2PKY

  • 492 Posts
  • 84 Reply Likes
If you are directly connected radio to PC with no network issues;
Open the Task Manager and check your CPU Utilization. This problem is usually associated with high CPU usage starving the radio for service. Check for other apps consuming cpu cycles.
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
Thanks Bill. I still need to try the direct connection method. However, my CPU utilization is 25-35% and memory is 15%. That should be sufficient, correct?

73 Chris
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
The error message you received indicates that the client (SmartSDR for Windows) has not received any network data from the radio for 15 seconds and resets the network connection. When this happens, if you can immediately restart SmartSDR and connect to the radio, meaning that the radio is still alive, then 99% of the time this is due to network related issues.  If you have to do a long power button press on the radio to reboot it, then the issue was the radio stopped responding.  You need to figure out which error condition you have before starting troubleshooting.

If it a network issue, then you should investigate what might have caused the network to not provide sufficient throughput to operate the radio.  Look at the entire end-to-end connection.  Is there a wifi element in the connection?  If so, that is the first place to look.  Wifi connections are slower and more unreliable that a wired Ethernet connection.  For every device connected to your wifi, the bandwidth decreases by 1/2. In addition, wifi is only half duplex. so that exacerbates congestion issues.   Adding wifi extenders cause these and additional problems by increasing the amount of latency on the wifi link.

Mack's recommendation is essentially a troubleshooting step where all of the network components in the end-to-end connection are eliminated.  This is a classic "divide and conquer" method of isolating the problem area.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
OK.  I have a good picture of your network configuration now.  Thanks.

In general, if I had to take a guess, I'd be suspect of the quality of the switch functionality in your wifi extender.  They are designed for handling bridged wifi traffic and it may not be up to the task of handling the data being streamed out of the radio to the PC or Maestro.  I'd consider using an external switch, like a Netgear GS308 that is connected to the wifi extender and then everything else in the shack connected to the GS308.
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
Unless we're saying the same thing or I'm not understanding you, I do have it connected the way you recommend. I'm using a NETGEAR ProSAFE FS105NA 5-Port Fast Ethernet Switch. The 6500, Maestro, PC, and bridge/extender all connect to it. There is only one wired connection to the bridge and that is between the bridge and the switch so I'm not using the bridge as a switch (It only has two ports anyways). None of the radio to PC or Maestro to radio data goes through the bridge. I don't think? It all goes through the Netgear switch. Does that sound right?

Thank you for your time and help.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
Ahh,  I see now.  

it is possible you have a marginal network cable.  I always suspect the physical layer when troubleshooting network performance

Where I'd look next is optimizing the network adapter in the PC.  This HelpDesk article address network adapter performance tuning.

https://helpdesk.flexradio.com/hc/en-us/articles/202118518-Optimizing-Ethernet-Adapter-Settings-for-...
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
And I forgot that you also want to use the network quality monitor in SmartSDR to see if you are dropping packets before and after making any adapter changes.
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
Thanks again Tim. I think I know a lot more about what I need to check.

73 Chris
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
I connected the radio directly to the computer last night and the issue stopped. I used the same LAN cable that I do between the radio and the switch. I guess next I'll try a different LAN cable between the switch and the computer.

Thanks for all of the suggestions.
Photo of k3Tim

k3Tim

  • 887 Posts
  • 178 Reply Likes
A  GS105NA 5-Port version is in use here.  On rare occasions (one / week) a hic-up occurs on the network. If connected direct to PC - never a problem (months at a time - 24/7). I'd suggest upgrading the switch. Also a fan of shielded Cat-6 cable, ground loops notwithstanding.

GL & BRs
Photo of Moose

Moose

  • 139 Posts
  • 4 Reply Likes
Thanks I may have to do that.