SmartSDR for Maestro v1.9.9 Winkey emulation still problematic

  • 1
  • Problem
  • Updated 2 years ago
I have been using the Winkey emulation in SmartSDR off and on since it was released with N1MM+ in RTTY and CW contests.

Though there have been great strides in working out the bugs, in my opinion it is still not ready for prime time. I will go back to my USB Winkeyer again.

When using a mouse to activate contesting functions and macros with the emulation, there is a perceptible lag between click and execution. Often one needs to click on the function buttons twice in order to send the contest message. The issue disappears if I use the USB Winkeyer.

I have tried all kinds of adjustments to the Winkey screen in N1MM+ to overcome the latency when using the SmartSDR CAT Winkey emulator but no joy.

I have a 6700, a very fast and nimble PC with factory installed, fresh Win 10 and the machine is used for nothing else except radio operation/logging. The Maestro is on Ethernet to a switch that connects to my WiFi.

If anyone has any fresh ideas, I am eager to read them.

73

Mike N1MD
Photo of Mike - N1MD

Mike - N1MD

  • 90 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 1
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1752 Posts
  • 535 Reply Likes
Have you tried the Maestro directly to the switch without going through WiFi? Just to make sure the latency is not in your network. 

I am not saying that is the solution, just one more test that might shed light to where the latency might be.
(Edited)
Photo of Mike - N1MD

Mike - N1MD

  • 90 Posts
  • 3 Reply Likes
Yes and no difference.
Tnx for your response and thoughts!
Mike
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
Are you using the latest updates for N1MM+?
Photo of Mike - N1MD

Mike - N1MD

  • 90 Posts
  • 3 Reply Likes
Yes -- 1.0.5924 released on 20 Sep 2016
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 808 Posts
  • 217 Reply Likes
We had a bug that is very similar to this identified in Alpha, That was resolved in 1.8.5.  Is this delay not there when you actually press the F key on the keyboard?  ONLY when you use the mouse on the GUI?
Photo of Mike - N1MD

Mike - N1MD

  • 90 Posts
  • 3 Reply Likes
Chris, I need to test the F keys. I was so focused on the mouse issue that I neglected to test the function keys.
I am all set up for the CQWW RTTY contest starting tomorrow so do not want to reconfigure away from the hardware Winkeyer to the software emulation until that contest is over. I will test the F keys early next week.
Thanks for your help.
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 808 Posts
  • 217 Reply Likes
No problem.. just drop me a note when you are able
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 808 Posts
  • 217 Reply Likes
Oh and good luck in the contest! Have fun and share your experience afterwards!