SmartSDR crashes when monitor goes to sleep

  • 1
  • Question
  • Updated 2 years ago
SmartSDR crashes when monitor goes to sleep or wakes, can't tell due to lack of visibility. But please not that PC is not set to sleep, but is set in power settings to run 100% of the time. I use windows 7 on i5 NUC computer with all updates installed.
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes

Posted 2 years ago

  • 1
Photo of Tony Taddeo

Tony Taddeo

  • 67 Posts
  • 30 Reply Likes
I would double check your settings as I suggest you are losing network connectivity. You can check this by trying to ping the computer over the network from another machine when the screen goes blank.

Tony
VK5TT
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
Nope, it running 100% of time.
Photo of Bill W2PKY

Bill W2PKY

  • 564 Posts
  • 104 Reply Likes
Your network adapter might be going to sleep. Check the power option on the adapter.
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
Checked all items and when monitor sleeps and is pingable up 100%.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
Also check power management in Windows 7. Try setting it to high performance.

Dave wo2x
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
Has been set to high performance sinc day one on this computer and OS.
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1607 Posts
  • 783 Reply Likes
The i5 NUC seems to have a variety of issues like this.

Enough variations that you'd have to do some research on your specific model, generation, driver and all that.

It isn't just any one thing apparently either.

73

Steve
K9ZW
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 919 Posts
  • 346 Reply Likes
Is SmartSDR actually crashing or just disconnecting from the radio?  If a true crash, could you post a screenshot of what you are seeing?  This might help us to understand what is going on.  Without that information, the others are on the trail of the most likely scenarios for this kind of issue (power management, power saving mode, etc).  I understand WH6HI has this already checked this, but I include this here for others that may run into this same problem.
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 341 Posts
  • 70 Reply Likes
I've been running dual monitors that go to sleep after 2 hours for 3 years will all versions of SSDR including all the ALPHA for the past 2 years  with out a problem. I have set everything the like network adapter, USB ports etc to never go to sleep or to go power saving mode. The only thing that shuts down are the monitors. 
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4063 Posts
  • 981 Reply Likes
I wonder how Pat is doing with his problem?
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
HI all,  thanks for sticking with me on this.  Looks like the issue is in the ethernet.  Can't figure out which setting are causing the issue.  Power saving  sleep etc.  will keep looking. 
thanks again for your help.
(Edited)
Photo of k3Tim

k3Tim

  • 943 Posts
  • 197 Reply Likes
There is a sleep setting in the driver itself that one has to change via the device manager.  It sounds like you caught that, however.
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
My solution for now is to just turn sleep mode for the monitor off for now.  I am to busy with other things to continue the trouble shooting.  So thanks to all that made suggestions.  Not giving up just have lots of other things that need to get done.