SmartSDR crashed, now booting 2.1.32 says it needs an upgrade and stalls at initiating hardware.

  • 1
  • Problem
  • Updated 8 months ago
So I was monitoring 20m on the Maestro and the audio stopped.  I looked and it basically said SmartSDR crashed.  I rebooted it and started it up again.   

Once it got to selecting 2.1.32 version, I started it and it said it needed to update and started going through the update process (1/4, 2/4, 3/4, 4/4 etc)  I believe at 4/4 it said it was initializing hardware and it starts showing this letters in parentheses.  It cycles through them over and over till it finally just fails and has to be rebooted only to do it again.
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of YV5WZ

YV5WZ

  • 393 Posts
  • 48 Reply Likes
Hey David!


What model?

Best Regards

George, YV5WZ / PY3ZZZ
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2968 Posts
  • 652 Reply Likes
After the crash the processors did not reset properly. Turn radio off un plug the power cord for 15 seconds reconnect power cord and re boot.
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
I picked it up used on QRZ.  Looking at the front and the back of it, I don't see an exact model number, only the serial number on the back and it won't boot to look at any menu in the radio except for select a version / WiFi setup, etc

As for turning the radio off.  I did pull the plug and even pulled the battery out of the back.  Yet it's still on so I'm guessing there is also an internal battery besides the one in the compartment on the back.

I'm unclear how to reset the processor since I can't prevent power from reaching it unless I just let whatever battery it's using to run dead.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2963 Posts
  • 642 Reply Likes
If it is the internal battery problem, then it will need to go back to Flex for repair. If the battery is not kept charged while not in use this can happen.
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
This all started when the Maestro was in use and plugged in.   SmartSDR errored and had to be shutdown.  When the Maestro rebooted, it said that 2.1.32 version needed to be updated and that update never completed.  Now, every time I boot it.  It tries to complete the update, but fails and says the hardware failed to respond.   (while booting and stuff, the black-lit buttons are randomly flashing, which I don't recall happening prior to this.  (though I could be wrong)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2963 Posts
  • 642 Reply Likes
If know one replies here with a fix for you, then open a help desk ticket so they can work with you on getting it fixed.
Photo of K1SZO

K1SZO

  • 32 Posts
  • 0 Reply Likes
Just an update.   I removed the power plug, removed the battery in the back and let it run until it wore down the internal battery and the Maestro would no longer boot.  (I was hoping to kill all power to the hardware allowing a real hardware reset)

Once it wouldn't boot anymore, I plugged it back in and booted it up.  Choose 2.1.32 version and it said it was finishing an internal update, but rather than getting stuck at initializing hardware.  It flipped right past that and SmartSDR booted up connected to my 6400!

Problem resolved. 

73, Dave ~ K1SZO