SmartSDR CAT "Slice not Present" question

  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I am beta testing one of the major commercial Rig Control / logging programs in order to add FlexRadio support. This SW must interface via serial so I must use SmartSDR CAT to create the serial COM link.

When operating on a local LAN and SmartSDR everything works fine with SmartSDR CAT displaying "Auto Switch TX" in blue. The 3rd party Rig Control program works properly. But when I switch to my remote site, SmartSDR CAT displays "Slice not present" even though the correct slice is actually displayed on the PC.

I have identical 6500's at both locations and both locations are working normally both with the PC access and via Maestro ... except for CAT. I am using Beta_1.10.15 but I see the same issue on previous CAT versions. The only obvious difference is the average ~55mS RTT ping times when connecting via the remote site.

If SmartSDR CAT is using UDP packets, that might be the issue as they will not be forwarded remotely in my system. I have not had a chance to look at the NW traffic while doing this. My network linking isn't a typical VPN connection.  

So my questions are:

Does SmartSDR CAT use UDP to connect the slice?

Is anyone remotely using a Rig Control program via SmartSDR CAT and VPN successfully?

Any known issues with longer RTT ping times or suggestions?

Fred
K9SO
Photo of Fred GLENN

Fred GLENN

  • 52 Posts
  • 6 Reply Likes

Posted 1 year ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8657 Posts
  • 3248 Reply Likes
The CAT application connects to the radio via a TCP port, not UDP.  Since you have two 6500s and they are connected via a bridged VPN, are you sure that the instance of CAT you are interested in is connecting to the correct 6500?  You can place your mouse cursor on the "Radio Connected" message in the space below the title bar of the CAT application to see the nickname of the radio it is connected to.

You may have to use a filter file to ensure that the correct radio is connecting to the correct instance of CAT.  

here is an article on how to use the filter file.

https://helpdesk.flexradio.com/hc/en-us/articles/202549169-How-to-prevent-multiple-FLEX-6000s-from-s...
Photo of Fred GLENN

Fred GLENN

  • 52 Posts
  • 6 Reply Likes
Yup. That was it. Simpler solution for me is just to turn off the other radio. Connects just fine. 

Thanks once again

73,
Fred
K9SO