SmartSDR CAT Port Not being Displayed in Device Manager

  • 1
  • Question
  • Updated 1 year ago
I have 3 ports defines in SmartSDR Cat, 19..20..21. When I look at the ports in device manager I see 21...121 and 22...122 but no port 19 pair. I set port 19 in Omnirig for SmartSDR. I am using Omnirig to connect Log4OM to SmartSDR and it works just fine. How come I am not seeing the port pair in device manager??

Thanks and 73,
Harry
W0LS
Photo of Harry Williams

Harry Williams

  • 88 Posts
  • 8 Reply Likes

Posted 1 year ago

  • 1
Photo of Harry Williams

Harry Williams

  • 88 Posts
  • 8 Reply Likes
Forgot to mention, using Win 10 and SmartSDR 1.9.13....
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 170 Reply Likes
Hi Harry (is that from a movie?)

Serial ports... I just went through another exercise in getting my serial ports working properly. They all came up missing in SmartCAT.

First suggestion... helpdesk ticket. Any other suggestion I might make might not help or even worse, might break things.

The first thing I do now when I have problems with serial ports is run COM Name Arbiter Setter found at: http://www.uwe-sieber.de/files/com_name_arbiter_setter.zip

If you run this without administrator privileges you can review the list of ports Windows things is active. What I see sometimes is that a pair is named but not checked. When I check the pair and apply them they start to show up. If this is what you see you can restart the program with admin privileges, apply and it will update the registry.

I also see - almost every time I start this program - a whole bunch of com ports marked as in use. Before I add any com ports in SmartCAT I check this program first and uncheck/apply every unused port.

Why this is happening I don't know. FRS blames Microsoft. Microsoft doesn't seem to care. It is what it is. Let's outsource.

Good luck & 73,
Kev K4VD


"Hi Harry": I'm thinking of Liv Taylor in Armageddon. 
(Edited)
Photo of Harry Williams

Harry Williams

  • 88 Posts
  • 8 Reply Likes
Thanks Kevin, I will check this out in the morning and let you know what I see.

Harry
Photo of Harry Williams

Harry Williams

  • 88 Posts
  • 8 Reply Likes
Well today I brought up the computer and went to device manager and the two missing ports are now there...go figure. Anyway thanks Kevin for the help and I have downloaded the "Arbiter" app so I have that available in case I have further issues. Thanks for your help...

73,
Harry
W0LS