SmartSDR CAT missing VSP

  • 1
  • Problem
  • Updated 4 years ago
Missing VSP, see error message
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes

Posted 4 years ago

  • 1
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
Running version 1.5.1.152. No issues until this morning
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 601 Posts
  • 130 Reply Likes
Got to "Services" in Windows and look for VSP.  Windows has turned off the automatic start.  Start it manually and change the setting to "Automatic" or "Automatic Delayer'.  It happens to me everytime Windows does an update.
Photo of Bob G   W1GLV

Bob G W1GLV

  • 795 Posts
  • 144 Reply Likes
The actual service name is "Virtual Service Port kit". The reason I'm saying this Rick is if a person is looking for "VSP" he/she will never find it.
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
Thanks, seems to be working, now if I can remember the next time :)

73's
Lew
N4CO
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 325 Posts
  • 77 Reply Likes
Me too!  I frequently see this message.  I reported it, and support folks told me how to manually start the service, which I can do, but it is only a workaround.  The problem seems to be related to delays with Windows startup on a "big" machine with lots of things to do during boot up.  Even setting the service startup to "retry" several times does not always solve the problem.  The message to affected users seems to be that SSDR CAT is only a bridging strategy until the world catches up to native SSDR interfaces.  That's fine, but it doesn't help in the here and now.
Photo of Bob G   W1GLV

Bob G W1GLV

  • 795 Posts
  • 144 Reply Likes
Martin, the service must be set to automatic. Windows loads services early in the startup process and sometimes the service will not function properly if loaded too late.
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 325 Posts
  • 77 Reply Likes
Tnx Bob -

The service is set to automatic, and the "recovery" options are set to restart the service -- as suggested by FRS.  (On "first failure", "second failure", and "subsequent failures"! We also have the option to have the system reboot itself upon service failure, but that seems a tad excessive.) Still, the service fails maybe 30-50% of the time on cold startup on my i7-920 system.

If I wait for the machine to quiet down after boot up, I can always start the service manually - from the Win7 "Services" dialog.  Then I have to start SSDR CAT manually, also.

It's not the worst problem to have, but it indicates that SSDR CAT needs a little work.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
Martin - do you by chance have a solid state hard drive for your boot disk?  We are seeing instances on fast machines where the boot process is no longer disk bound causing processes to timeout or fail to start altogether.  We are trying to characterize this issue, but it is very machine / OS / and installed apps dependent.
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 325 Posts
  • 77 Reply Likes
Tim - No SSD on my system.  I do have some background apps that automatically start up, like BOINC.  (BOINC runs big scientific jobs in the background. I find that I can "donate" > 50% of my system this way without apparently hurting SSDR.)  I haven't tried experimenting by removing this service. It might help with VSP startup.  There may also be "cobwebs" in the system from earlier development projects.  (Sigh.)

I do have a slow boot.  It can take nearly 5 minutes from boot to quiescent desktop.  Ironically, my "slower" systems boot a lot faster. (Time to reload the OS? Migrate to W10? :) I can give you more details off line.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
Official Response
We are going to be adding the automatic restart on service timeout (which I strongly suspect was Lewis' issue) to the FlexVSP service in an upcoming release of SmartSDR.