SmartSDR CAT 1.3.8 problem

  • 1
  • Problem
  • Updated 5 years ago
I have been running SmartSDR 1,3,8 for some time with no problems.  I have been trying to get 3rd party programs (Logger 32, FLDIGI) to communicate via SmartSDR CAT with no success.  CAT loads, however no Com ports are created.  The CAT Main screen shows the Flex radio, S/N, and IP Address and it shows "Connect 3rd party program to COM 4".  When I go to the Serial Ports screen, no ports appear.  I tried adding a port and I get a message "Unable to create a new pair...."  A check of Device manager on the pc, running Windows 7 64 bit, the only com port shown is COM 12 which is for the Flex control.
I reinstalled the entire Smart SDR program with no change.  I then totally uninstalled the program elements and I scrubbed the registry.  I again installed, directly from the download site,  SmartSDR.  Again, no com ports are created.
Any suggestions would be greatly appreciated.
73, Bob, KN4HH
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1680 Posts
  • 616 Reply Likes
Have you checked in Device Manager for phantom COM ports? Click to show "hidden" devices - there could be several. Delete them and reboot. Try creating again from SmartCAT.
Photo of Luis del MOlino

Luis del MOlino

  • 50 Posts
  • 5 Reply Likes
Instructions received from Tim Ellison

Tim Ellison (FlexRadio Systems)

Oct 06 01:44 PM


You can try a manual install of the VSP drivers.

1.) Make sure that the CAT program is not running. Close it if it is.
2.) Locate FlexVSPInstaller_xx.msi where xx is 64 or 32 depending on if your version of windows is 64 or 32-bit. The file is in the path:
\Program Files\FlexRadio Systems\SmartSDR v1.3.8\xx-Drivers\VPS (again, xx is either going to be 32 or 64)
3.) Right click on FlexVSPInstaller_xx.msi and select Install from the drop down menu.

This should install the FlexVSP drivers. After they install, reboot your PC.

Then check in Control Panel to see if FlexVSP is installed.

Luis EA3OG

Photo of Steve W6SDM

Steve W6SDM

  • 625 Posts
  • 283 Reply Likes

After you do that, if you still have problems getting FLDigi to work, let me know and I will send you my screen shots.

Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
Thanks for the suggestions. First no phantom ports present.  I reinstalled VSP 64 bit and still no com ports are created.  i am beginning to think it is a pc related problem.  However, I don't know why the pc would prevent com ports from appearing.
Photo of Don


  • 109 Posts
  • 6 Reply Likes

Had a similar problem. Norton Anti-virus decided to block ports. Had to uncheck port blocking.


Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
Don, you hit it right on.  I disabled my anti-virus program and reinstalled VSP and the com ports are there.  Thanks so much to you, Don, and all the folks in the Flex community.
73, Bob, KN4HH