SmartSDR 3.18 problem

  • 1
  • Problem
  • Updated 4 weeks ago
  • (Edited)
I have just upgraded to SmartSDR 3.18 and have struck what I think is a problem.
The software loaded correctly with no problems.
How ever when I run SmartSDR it comes up in Smartlink mode.
If I log out of Smartlink the start menu tells me that there is no radio connected to my LAN.
I have a 1 Gb ethernet cable from the radio to the router.
I have set the 6700 to a fixed ip address and can ping it from the commend prompt.
With the previous versions you could operate with out Smartlink and only neede to login if you needed to operate from a remote site.
Any advice would be appreciated
Further test has revield that if I turn my internet connection off I cannot use the radio at all.
Photo of John VK3XM

John VK3XM

  • 46 Posts
  • 5 Reply Likes

Posted 4 weeks ago

  • 1
Photo of YV5WZ

YV5WZ

  • 423 Posts
  • 50 Reply Likes
Menu

Settings:  Choose Radio / SmartLink Setup
Photo of John VK3XM

John VK3XM

  • 46 Posts
  • 5 Reply Likes
Thanks for the suggestion.  However I have checked the menu on the logon screen and the Smartlink option is not ticked.  I don't seem to be able to get the software out of Smartlink mode.

Have tried a factory reset.  No difference.
Photo of Michael Walker

Michael Walker, Employee

  • 1097 Posts
  • 325 Reply Likes
John

Can you tell me the ip address of the radio and the computer.

Can you also describe your network setup.

When this happens the computer is usually not on the same subnet as the radio but both devices have internet access.

Mike
Photo of John VK3XM

John VK3XM

  • 46 Posts
  • 5 Reply Likes
Hi Mike,  my LAN is a simple configuration  with the PC and Flex directly connected to the router.  You are right the PC and Flex appear to be on different sub nets.

I can ping the PC and Flex.  The Flex responds to both the local LAN address and the remote IP address.
To me it appears as though the Flex will not release the SmarLink address,  no matter what I do.

This problems only started when I upgraded to 3.18

I am not comfortable to put my Wan addresses on the Community.

I do have Team Viewer on the PC if you would like to use this.

Regards John
Photo of Michael Walker

Michael Walker, Employee

  • 1056 Posts
  • 314 Reply Likes
Hi John It’s not the wan address I was looking for, but the lan address. It sounds like your windows firewall is turned on and blocking Vita 49 packets from communicating directly with the radio. This can happen and still have ping work correctly.If turning off your firewall or adding a bypass does not fix the problem, then I would recommend opening a support Ticket. Mike
Photo of Santiago Mejia - HI8SMX

Santiago Mejia - HI8SMX

  • 87 Posts
  • 5 Reply Likes
Something like that happened to me recently preventing me from upgrading my SDR version. The fix that worked for me was:

 a) Power down both your radio and computer.  Remove all power from the radio for 30 seconds.b) Connect your radio directly to your computer using a CAT5 or CAT6 cable.c) Boot up your computer.  Wait for it to finish booting up completely.d) Power up your radio.e) open SmartSDR for Windows.  See if the radio is available
f) if it works, connect radio and computer back to router
g) do a cold boot

see if the radio is available without Smartlink then.

hope this help.

73, Santiago HI8SMX 
Photo of John VK3XM

John VK3XM

  • 46 Posts
  • 5 Reply Likes
Thank you to everyone who offered advice.  I eventually found the problem.
A couple of hours before I did the 3.18 upgrade my Avast Internet Security updated it self.  When I turned Avast off everything worked again.  When I check the settings in Avast I found a new setting that need a tick in the firewall panel.


So I am up and running again.

Thank you to all who offered advice,  and thank you to Tim from Flex who also helped.

73. John VK3XM