SmartSDR 1.9.9 and N1MM a bust for WWRTTY Contest

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Windows 10 update, SmartSDR v1.9.9 and N1MM+ turn out to be a disaster for the WWRTTY contest this weekend.  My setup would work and then it wouldn't for no reasons that I could contemplate.  Had I realized that 1.9.9 was a fix for CW I would not have loaded it although the Windows 10 update would probably been just as bad.  Having to uninstall, manually remove DAX drivers, rename or delete install folders and reconfigure everything 4 times just took all the fun out of it for me. 

I got everything loaded, tested and made two contacts Friday night, shutdown everything normally and went to bed.  Got up at 3am Saturday and had Maestro's speaker screaming when I transmitted.  Shut off Maestro and went to SmartSDR, all went well until Honey Do's came.  Shutdown radio and software but when I returned at 5pm neither Maestro or SmartSDR will transmit.  N1MM is complaining that comport4 is not responding even when it is decoding signals.  Oh and Hawaii stations won't log because N1MM says that 31 is not a recognized zone.

Enough frustration for me I'm done until things get more reliable.  No joy in my hobby this week end.

Warren
NU7R
Photo of Warren Gaspar

Warren Gaspar

  • 21 Posts
  • 4 Reply Likes

Posted 3 years ago

  • 2
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
Not sure if it will make you feel worse or better, pretty much the same here BUT I did not switch to 1.9.9.1  until 1.9.7 stated causing RTTY issues after Windows 10's recent upgrade.  I have spent most of today working on RTTY issues and have made zero contacts so far.  Lost a needed DAX port, solved it, then TX would not work.  Solved that, then something else would not work.  Most likely lots of pilot errors bit a very frustrating day . 
Photo of Walt

Walt

  • 236 Posts
  • 75 Reply Likes
running 1.9.7 win 10- which updated yesterday - and writelog - band conditions tough but been making contacts for 24 hrs. have not seen any problems.

hope things get better for you
Cheers
Photo of Phil m0vse

Phil m0vse

  • 208 Posts
  • 38 Reply Likes
Exact opposite experience for me, 1.9.9, N1MM+ and Maestro have worked flawlessly for me all day using S02R. As for Hawaii stations, are you using the latest N1MM+ and the correct contest as it just worked fine for me (using KH6Y as a test callsign). 

I suspect other issues as I have not have to remove/reinstall DAX for quite a few versions now (on Windows 10), I just make sure that I close DAX/CAT, remove the previous SmartSDR version (NOT removing DAX) and then install the new one. 
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3787 Posts
  • 913 Reply Likes
Yes I don't think he should have removed Dax drivers when re- installing, I think Flex is clear on that.
Photo of WX7Y

WX7Y

  • 755 Posts
  • 153 Reply Likes
This last update for Win10 update really destabilized things at my QTH
From changing my default audio device, breaking the CAT drivers, Breaking my Win-Node watt meter drivers to who knows else.
I will NOT be blaming FLEX upgrades for Windows 10 crappy untested updates in my stations problems though where the blame lies totally with Microsoft

73 WX7Y
Photo of WX7Y

WX7Y

  • 755 Posts
  • 153 Reply Likes
My version here is WIN10 Pro 1607, Build 14393.187 that updated over night, I do have things set now for Manual update. 
73's WX7Y
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
Official Response
Warren is a close friend, and I am taking care of this issue for him.   He got Win-Owned by the Anniversary update.  He was running Windows 10 Pro but hadn't blocked automatic updates. 

I HIGHLY recommend that if you are using a PC dedicated for your Flex activities that runs Windows 10, that you update to Pro and disable auto updates so you can apply them when it is appropriate and not let Windows kill you the night of the contest.  Look in this link where gpedit.msc is used to apply a policy change to block it.

http://www.howtogeek.com/224471/how-to-prevent-windows-10-from-automatically-downloading-updates/
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
Yep, Microsoft really did in a large number this week.  It wasn't just hams.
Photo of Kevin

Kevin

  • 931 Posts
  • 271 Reply Likes
Running Win10 1511 (OS Build 10586.589). Is that the new edition? SmartSDR is running 1.9.9. I'm running CQWWRTTY with 5 watts and while it is a struggle to make contacts I can't blame much on the OS or the software. There was one time when N1MM+ (1.0.5924.0) locked up but a quick restart of the app got everything reconnected.

I'm not going to question why these problems are cropping up and I'll just knock on wood that so far I've been safe.

Any bugs found have been with the wetware. That version is still in alpha testing.
Photo of Rory - N6OIL

Rory - N6OIL

  • 301 Posts
  • 55 Reply Likes
If you guys don't want Win 10 then I would run this little app from Steve Gibson https://www.grc.com/never10.htm
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 198 Reply Likes
For those in the know ... I have an update / reboot for Win 10 scheduled.  How do I turn that off?  All I can seem to do is delay it a day.  This is for 1607.

I think I can roll it back, but I only have 10 days to do that.

Mike
Photo of k3Tim

k3Tim

  • 901 Posts
  • 186 Reply Likes
Hi Mike,
I'm not in the know, more like in the no.  Was never able to stop a Win 10 update (Pro) but kept delaying it though eventually the update happens. The big 1607 update was fine and only broke VPS/CAT here and maybe one channel of DAX. These I reinstalled and all is well.  Fldigi is working fine during the RTTY contest although the participation level is rather subdued. 

"go for it"

Tim
Photo of Craig K9CT

Craig K9CT

  • 42 Posts
  • 46 Reply Likes
CQ WW RTTY M/2

We are running both Win10 and Win7 here on the network and have 5 stations running. We are running Networked N1MM + and have version 1.9.10 without any issues. I would shut off the updates when contesting.....you should do them when it is safe to test. Sorry to hear about the problems, but I don't think this is FlexRadio related. 

73, Craig K9CT
Photo of Warren Gaspar

Warren Gaspar

  • 21 Posts
  • 4 Reply Likes
I really appreciate all the support as I let out my frustrations.  Chris, K6OZY was extremely helpful last night walking me through cleaning up Windows 10 hidden ports (they were a mess from 5 days of removing and reinstalling software). 

Yes this is basically a Windows issue and not SmartSDR.  It is also how different programs such as N1MM, FLDigi and DXLabs interact with each other (that's a different can of worms but is what led to all of this).

I now have Windows Updates turned off!  I will run them manually myself but it really will only take the urgency out of the problem in that it can't break things in the middle of a contest but it will still break things.  The procedures to clean up the mess that windows makes because it doesn't properly (in my opinion) delete drivers when they apps are removed. 

It took Chris and I 2 hours to get everything uninstalled and the did a clean install and a wonderful SO2R installation.  I spent 2 hours S&P on 40M last night and all worked as advertised.

On the Flex side of things releasing an update to SmartSDR that fixed a CW issue the day before a RTTY contest just added to the confusion.  I was told that v1.9.9 had specific fixes for N1MM (true but not for RTTY) so even though v1.9.7 was working properly I did the upgrade.  I now am having issues with Maestro blaring my transmit signal out of it's speakers at full volume with no volume control available.  I was able to re-create the problem last night, by accident, when I changed from 40M to 80M then back to 40M.  I had been running S&P successfully so I decided to try RUN instead.  As soon as I hit F1 the speaker blared and the signal was transmitted.

I gave up, shut everything down and went to bed.  This morning all is well again, I have been able to work both S&P and RUN and have changed bands without any issue.  Only the radio Gods know what is going on but the blaring sound did not exist prior to v1.9.9.

At this point I consider this issue resolved.  I'm going to try to put together a procedure that fixed it all and post for anyone who needs the help I received from a friendly Ham who reached out to me and assisted with a solution.

I LOVE FLEX RADIOS AND WILL NEVER USE ANYTHING ELSE.  THEY REVIVED MY ENJOYMENT OF A HOBBY I HAVE BE DOING FOR OVER 50 YEARS.

IN THE END THIS POST SHOULD BE CHANGED TO PRAISE AND NOT A PROBLEM NOW.

73'S,

WARREN
NU7R
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 922 Posts
  • 260 Reply Likes
Glad to hear Chris got you dialed in.