SmartSDR 1.5 WNB problem Flex 6300

  • 1
  • Problem
  • Updated 3 years ago
Just loaded SmartSDR15. on my 6300. Turned the level of the WNB all the way up (100) and found that after about 10 seconds the receiver went deaf for a short period and then recovered... Tried that several times with the same results. No unusual noise present. Bug #???
Photo of vincentjlawrence

vincentjlawrence

  • 7 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2762 Posts
  • 610 Reply Likes
I seems to be working as it should. You need to set the AGC-T correctly then turn on WNB and adjust the slider carefully till the noise goes away.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
You have the WNB aggressiveness turned up too high.  You should never need to set it all the way to 100.  When it is too aggressive, it cannot differentiate between what is noise and what is signal.
Photo of vincentjlawrence

vincentjlawrence

  • 7 Posts
  • 0 Reply Likes
Tim, if as you say "You should never need to set it all the way to 100. When it is too aggressive, it cannot differentiate between what is noise and what is signal." Then you should limit the algorithm to the highest level that does not drastically impair the receiver as it does now. I consider this a bug as I reported it because as you say "...it cannot differentiate between what is noise and what is signal. This statement in itself is an admission of a "bug".

Regards,

Vince
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes
And that is precisely where Lee had it set in his very impressive videos.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
I said never "need" to, not don't ever do it.  We allow for some "overhead" in the aggressiveness setting for WNB.  In certain circumstances WNB will work with the threshold set to 100, in most causes a value less than 100 is optimal. 
(Edited)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2756 Posts
  • 609 Reply Likes
Tim, If I understand this, The WNB re-creates it self as conditions change. So you can't just set it and forget it, we may need to move the slider a bit if the noise changes, is that right?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
WNB will "retrain" when it experiences variances in signal levels.  The threshold or aggressiveness does not dynamically adjust for these changes, so yes, there are situations where you will have to readjust the WNB threshold.  For most short term situations, it is a set and forget control, like NR, but if the noise/band/signal characteristics change significantly, resetting the WNB aggressiveness will be required.
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1561 Posts
  • 552 Reply Likes
Vince, I respectfully disagree. Depending on conditions, aggressiveness of the function might find a place close to "maximum" and I'd like to be able to adjust it all the way to the limit. Bill's advice is excellent: AGC-T first, then careful WNB can work wonders - seriously - on some noise. It's not a magic bullet against all forms, but that's why we have AGC-T, ANF, NR, filters, etc. 

It is not a set and forget control, or one that can be used easily by toggling on or off. For some, this may be a problem. I'm on 160m right now, and the difference with my local noise, etc., is a good S-Unit. That's huge.
Photo of Stan - VA7NF

Stan - VA7NF

  • 416 Posts
  • 92 Reply Likes

It is with deep regret that my type of noise (actually severe distortion of a 270Khz digital ballast) is not attacked with WNB; but hope springs eternal.

Now if there were a way to capture the IQ information and send it to FRS to use against any future algorithm.

 Formula for noise:  Take a 270Khz square wave, modulate with 600Hz half sine, further modulated by 60Hz half sine.  Result: HF wipeout.

Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3969 Posts
  • 1225 Reply Likes
I think I once recorded a 48,000 sample rate IQ DAX channel with Audacity and my 6500 and listened to it with my 1500.  You might try that and see if it works.  It was a long time ago and  don't remember how well it worked......