smartlink unable to connect at remote sites

  • 1
  • Question
  • Updated 11 months ago
I have Smartlink set up on my 6500 and it works well from within my home over the WiFi.  However, when I try to connect to my rig from a remote location (On a public wifi, for instance or from my work location), I frequently get a 'Smartlink cannot connect - please retry' message.  

As far as I can tell, I'm connected to the internet, the upload and download speeds are in the 20mb/sec range and I can see the radio.

What might be causing that message?

Thanks for your help.
Photo of VE7ATJ

VE7ATJ

  • 124 Posts
  • 22 Reply Likes

Posted 11 months ago

  • 1
Photo of Bill  /  VA3QB

Bill / VA3QB

  • 124 Posts
  • 14 Reply Likes
Sounds like the ports may not be set on your router. Check the Smartlink setup procedure.

Bill
VA3QB
Photo of VE7ATJ

VE7ATJ

  • 124 Posts
  • 22 Reply Likes
Hi Bill.. I've been through the setup procedure a couple of times and everything seems to work fine over Wi-Fi at home.  It's just when I'm attempting to connect via the internet.  What port setup are you referring to?
Photo of Bill  /  VA3QB

Bill / VA3QB

  • 124 Posts
  • 14 Reply Likes
Ports 4493 and 4994 forwarded to your radios iP address. You should also configure your radio to a static iP address.

Bill
VA3QB
Photo of Winston VK7WH

Winston VK7WH

  • 248 Posts
  • 42 Reply Likes
Can you do this (configure the Radio to a static IP address) Bill? I thought I read somewhere where Flex (possibly Tim) said that you couldn't assign a static ip to the Flex.

I hope I am wrong because a fixed IP address would solve an intermittent disconnect problem I am experiencing on occasions.

Winston
Photo of Bob Gerzoff, WK2Y

Bob Gerzoff, WK2Y

  • 161 Posts
  • 13 Reply Likes
I am not sure about how it would relate to the ports, but you can definitely assign a fixed IP address.  Now that I have resolved some issues I had having two routers, however, I haven't needed too and rarely have any issues.  But I'm not to the point of trying to access remotely.
73, Happy New Year
Bob
WK2Y
Photo of Bill  /  VA3QB

Bill / VA3QB

  • 124 Posts
  • 14 Reply Likes
I let the radio pick its own iP address then I tell the router to reserve the iP address. This way it uses the same iP address each time and allows you to configure the ports appropriately.

Bill
VA3QB
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3479 Reply Likes
Photo of Bill  /  VA3QB

Bill / VA3QB

  • 124 Posts
  • 14 Reply Likes
First rule of thumb.... Rip out any ISP provided router. Ask your ISP to take the router out of the equation. There are many good routers for the home market. Dlink, Tplink and Net gear.
Make sure you buy the router before bypassing your ISP router. If you need help setting up a new router we can do it via email.

73
Bill
VA3QB
Photo of VE7ATJ

VE7ATJ

  • 124 Posts
  • 22 Reply Likes
Thanks for the advice, Bill, but it's not going to be that easy.  In my home, because of the configuration of my heating ducts, etc. the ISP has had to build in branches and boosters to get everything to work on a regular basis.  So, it's not as easy as simply replacing one router, and I'm afraid I don't have the technical skills to get into replacing the network they've set up.
Photo of Bill  /  VA3QB

Bill / VA3QB

  • 124 Posts
  • 14 Reply Likes
You could add a second router to the modem.  Just not sure on how you would do it ...  Your setup sounds complicated.  It sounds like your running everything wifi so the need for boosters.  I run nothing for hamradio on wifi. 

Oh well good luck. 

73
Bill
VA3QB 
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1209 Posts
  • 249 Reply Likes
You. Can try leaving the vendor router in place, then log into the. second router and see if there is an option to set it as an access point. This way you are not double NATing. Which is most likely keeping it from working.

I do it here with a pair of Asus routers.

Dave wo2x
Photo of Bob Gerzoff, WK2Y

Bob Gerzoff, WK2Y

  • 161 Posts
  • 13 Reply Likes
And do make sure you set it as an access point (disabling DHCP) with same SSID as the rest of network.  For the longest time, I had no end to grief with unable to connect and dropped connections because I hadn't done that. Basically it resulted in two different networks that didn't communicate well.  I also have an ASUS router and it is easy to set up as an access point(one click.)  My main router is IQRouter which has been fantastic(amazing increase in speed), but it is connected directly to the cable modem. I don't think you can use it in this instance.
73, Bob WK2Y