Smartlink stopped working today

  • 1
  • Problem
  • Updated 4 months ago
Have been using Smartlink every day since I got my 6300 about a month ago. Stopped working this morning. Thought it might be a temporary issue so I left it alone until tonight. Still no joy. On 2 local win 10 machines, the Smartlink test fails (red). On my 2 iOS devices, the Smartlink radio is in the selection list but won’t connect - keeps returning to the “Tap here to connect” screen. Tried unregistering and reregistering the radio but didn’t help although the procedure seemed to have completed successful. Checked my public IP and it hasn’t changed. What do I do next? Thanks.
Photo of Ken, K2KXK

Ken, K2KXK

  • 22 Posts
  • 6 Reply Likes

Posted 4 months ago

  • 1
Photo of NA0B

NA0B

  • 28 Posts
  • 0 Reply Likes
Ken, have you tried a cold reboot of your 6300? Turn it off and unplugged it from the power supply for a few minutes before restarting the radio.
Photo of Ken, K2KXK

Ken, K2KXK

  • 22 Posts
  • 6 Reply Likes
Just sent tried that based on your suggestion but didn’t help. Thanks.
Photo of Michael Walker

Michael Walker, Employee

  • 318 Posts
  • 82 Reply Likes
Ken,

Did the IP address of the radio change on your network?  

I would also log into your router and review the uPNP values and see if the ports that SmartSDR thinks you are using are the ones that match in SmartSDR.  Also confirm that those ports are forwarded to the IP address of the radio and make sure they match.

Mike
Photo of Ken, K2KXK

Ken, K2KXK

  • 22 Posts
  • 6 Reply Likes
Hi Mike. Thanks for the reply. I think the ip of theradio May have changed. How do I fix it? I can give it a static IP address to prevent this problemin the future. Also, how do I know if the upnp ports are correct? At the moment they are forwarded to the radios former ip. How do I fix this mess? Thanks again.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1201 Posts
  • 245 Reply Likes
You should do a DHCP reservation in rhe router for the radio. Just set the reservation to the old IP and reboot the radio. Then no changes will be needed to port forwarding.

Dave wo2x
Photo of Michael Walker

Michael Walker, Employee

  • 318 Posts
  • 82 Reply Likes
Hi Ken

There are many ways to solve this.  One I use is to log into the router and look for some uPNP settings and sometimes you see one that says to delete all previous reservations on reboot, or something like that.  Then, when you reboot the router those ports are deleted and new forwarding rules are created to the new IP address of the radio.

The other is to do what Dave says and do a hard coded reservation in the router.  This means the radio always gets the same IP address when booted.  Then, do a hard coded port forward.  Hard coding means you look for the NAT section of your router and create a port forward rules (you need 2) to point to the actual radio.  It sounds more complicated that it is and you won't bream anything trying.  :)  You can always delete the rules if it doesn't work.

Mike
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1201 Posts
  • 245 Reply Likes
Since his SmartLink has worked with the previous IP it is probably easier to do the DHCP reservation with the old IP. He will need the MAC address of the radio which he can get by starting SmartSDR and going to Radio Aettings/Network

The router is already set for port forwarding to the old IP.

Dave wo2x
Photo of Ken, K2KXK

Ken, K2KXK

  • 22 Posts
  • 6 Reply Likes
Thank you all so much for the quick responses.  I took Dave's suggestion along with Mike;s input and all is working.  I did have to reboot the router (Netgear) not just the radio to get it all synced up.  Not one to leave well enough alone, I'd like to move the ip of the radio to a higher range where I have my other reservations and static IPs.  If I do that, how will I get the uPnP rules to follow?  I don't think I can edit them on my router but I can delete them.  How would I recreate them?  Or should I put in manual port forwarding?  Thanks again to all who responded.