SmartLink Password Reset link not working

  • 1
  • Question
  • Updated 5 months ago
I attempted to reset my SmartLink password using the forgot password link on the SmartLink log in page.  I clicked the link and it prompted me for my email address.  I then saw a message saying that the password reset routine was sent to my email address.  I waited for a hour and no message.  I tried the link again.  I got the same message and no email.  Have I missed something?

73, Bob, KN4HH
Photo of Bob  KN4HH

Bob KN4HH

  • 91 Posts
  • 21 Reply Likes

Posted 12 months ago

  • 1
Photo of Roy - W5TKZ

Roy - W5TKZ

  • 123 Posts
  • 12 Reply Likes
Bob,
Take a look in your spam folder. It might have been put in there.

Roy - W5TKZ 
Photo of Bob  KN4HH

Bob KN4HH

  • 91 Posts
  • 21 Reply Likes
Thanks, Roy.  No such luck.  Checked all folders.

Bob  KN4HH
Photo of Mike  W1BFA in Maine

Mike W1BFA in Maine

  • 87 Posts
  • 10 Reply Likes
I had a similar problem. Dudley got me straighten out. It turned out there was a breakdown in the setup confirmation sequence and my account never was properly confirmed. There was a message you had to acknowledge during the process. I never could see that I received it but I might have missed it. Anyhow, once Dudley was able to make the server show I was confirmed it all worked “like buttah”. My original password worked again.. Maestro and the IPad both function perfectly. Mike. W1BFA
Photo of Tim, VK6EI

Tim, VK6EI

  • 7 Posts
  • 0 Reply Likes

I am having the same problems, says it has sent an email but does not show up. Is it necessary to open a ticket ?


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Yes