Smartlink login issues

  • 1
  • Question
  • Updated 3 months ago
Trying Smartlink access for first time unsuccessfully. Radio is 6600. Client is SmartSDR for iOS on an iPad via 3rd part WiFi.. IOS client sits at “discovering”. Smartlink enabled on iOS client and I can successfully log in with Smartlink credentials. UPnP enabled on router (FIOS-G1100). No other changes made to router. Picture of uPnP forwarding screen att ached to post. How does one fault isolate Smartlink issues?

BTW, have not tried it with Maestro yet.

Ron, WB2WGH

n
Photo of Ronald Panetta

Ronald Panetta

  • 34 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Doug

Doug

  • 112 Posts
  • 33 Reply Likes
So I guess the Ipad is not discovering the radio ? It just sits there and spins and doesn't connect

Photo of Ronald Panetta

Ronald Panetta

  • 34 Posts
  • 0 Reply Likes
Doug, correct. Just sits and spins on discovery. All good when at home on same network as Flex. Discovery issue only when remote.

Remote is one of the 2 reasons I bought the iPad. The other is much more compact form factor than PC and Maestro while at home.

Should have titled it a connect issue and not a login issue. Hindsight is 20/20. Was thinking about that earlier today.

Ron WB2WGH
Photo of Ronald Panetta

Ronald Panetta

  • 34 Posts
  • 0 Reply Likes
ThinK i resolved issue. Will find out tomorrow when i can WiFi connect from a third party network. I never registered the radio with SmartLink. Just went through that process a few minutes ago. Looks promising now.

Ron, WB2WGH
Photo of Doug

Doug

  • 112 Posts
  • 33 Reply Likes
Ron did you get it going the reason I ask I am having the same problem only with the Ipad. A few times I have gotten it to connect the radio but can't seem to hold it but a couple of minutes. Here on my home network perfect.
Photo of Ronald Panetta

Ronald Panetta

  • 34 Posts
  • 0 Reply Likes
Doug, yes I did get it going. I was able to log into the radio from a Denny's restaurant wireless network. Performance was poor (serious application latency issues) and suspect that to be poor guest WiFi. I need to test some more with some other 3rd party networks and will update the thread after some additional testing.

For others that might experience the same SmartLink connectivity issue, I missed a step in the following guide:

https://www.flexradio.com/downloads/smartlink-quick-start-guide-for-smartsdr-pdf/

Steps from table of contents no longer required with V2.x software as SmartLink already included:
  • Obtain and Install the Software
  • Update the Radio
  • Purchase the Version 2 License
  • Refresh the License Info
Steps still required with V2.x:
  • Create the SmartLink Account
  • Register the Radio (This is the step I missed)
  • Test the SmartLink Connection (did not perform this step and a non-issue)
  • Connect to Your Radio

Without that missed step there is no SmartLink association between ones SmartLink account and your physical radio. I did that from the Maestro. I did have a few registration failures and had to repeat that step a few times. Not sure what was going on.

For reference, the local ISP serving my house is Verizon FIOS. Like I said, I'll update this after trying some other WiFi networks. First opportunity may be Tuesday unless I happen to go to a Panera (not a Starbuck's fan) with XYL in the interim :)

Ron WB2WGH
Photo of Ronald Panetta

Ronald Panetta

  • 34 Posts
  • 0 Reply Likes
Doug, 

Had much better luck at Panera today. One thing I did notice is that when the iPad screen locks, the app disconnects. I went into SmartSDR for iOS -> Settings -> Prevent device sleep -> enable

Did not actually have any QSOs as did not want to be disruptive.  

Ron