SmartLink compatibility?

  • 1
  • Question
  • Updated 1 month ago
Is SSDR V2.49 Smartlink compatible with SSDR V3.0 SmartLink?
I'm trying to connect using V2.49 to a remote site which is set up using V3.0 and a connection cannot be made.
Instead of the "Connect" key it comes up with "Upgrade". 
Which when selected, says its not available Yet.


Tom W3FRG
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes

Posted 1 month ago

  • 1
Photo of Michael Walker

Michael Walker, Official Rep

  • 829 Posts
  • 235 Reply Likes
Hi Tom

No.  All devices need to be at the same version.

Mike
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
Hi Mike,
Tnx as always for the quick response.

Will this hopefully be changed down the road so different versions can talk to each other using SmartLink?

Tnx Mike,  Tom W3FRG
Photo of Michael Walker

Michael Walker, Official Rep

  • 829 Posts
  • 235 Reply Likes
Hi Tom

It is connected to the radio licensing.  The Maestro would need to be a V3.  Did you try connecting to the radio as the Maestro should upgrade itself without issue.

You can then go back to 2.4.9 if required.

The only thing you can't do is upgrade the radio remotely over SL.

Mike
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1462 Posts
  • 738 Reply Likes
@Michael - If Tom is working from a PC, couldn't he also download & install the version of SmartSDR the radio is using?

Thinking the licensed end is the radio, not the end user's end?

73

Steve
K9ZW
Photo of Michael Walker

Michael Walker, Official Rep

  • 829 Posts
  • 235 Reply Likes
Hi Steve

Yes, of course.  You just can't upgrade or downgrade a radio remotely.

Mike
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
I'm operating from either a PC or Laptop, same results.
Put Ver 3 on the laptop but it doesn't do anything.


Tom W3FRG
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1462 Posts
  • 738 Reply Likes
@Tom - I had that trouble and here is what I found - the desktop Icon was opening a different version of SmartSDR than I needed.  I can't shoot you a screen shot as I have some test software running, but the naming convention includes the version.

So if the remote station is running v3.0.19 you need to download and installed v3.0.19 on your PC or laptop.  

That way you will open the right user end software to match the remote station.

73

Steve
K9ZW
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
I believe that's what I did, but no go. I'll look closer and re try.

Is there a way to remove a version from the radio out of curiosity?

Tnx  Tom
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes
Tom, 

Give me a call and I can TeamViewer in and give you a hand.

Dave wo2x
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
Hi Dave,

I probably didn't wait long enough before I tried to start the FRS 6600M at the remote site.
I just tried again, site was turned on for a few hrs by owner so starting 6600M was almost immediate.

The "WIDE" indication came up on all bands except 20m. I expect it on 60m.
The only way I was able to get "WIDE" turned off was to switch from ANT1 to ANT2.

I used a known working Profile for 80m from V2.4 and it worked fine, but "WIDE" was again present.

I created slices for A, B & C; Could not create one for D.

Tom W3FRG
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes
Hi Tom, give me a call during the day tomorrow (Thursday). I’m in the office anytime after 7 a.m.

I will not be availble between 3 & 4 p.m.

Dave
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
Dave,

The remote site has no PC  available, just the radio so there's no TeamViewer available to take a look see.
I omitted stating which ANT1 /2 that I was able to select, it was the Receiving ANT1 / 2 which changed the WIDE disappear.

I'll call around 0800 and hopefully be logged onto the remote 6600M for any troubleshooting.

73  Tom W3FRG
Photo of Michael Walker

Michael Walker, Official Rep

  • 829 Posts
  • 235 Reply Likes
If you see WIDE, then the band pass filters have been turned off.

Have a look at Section 32.4.1 in the manual.  I tried to paste it in, but it pasted in as a mess.  There are 3 examples there.

I suspect you are seeing wide since you zoomed out past the preselection filter bandwidth with 1 or more receivers.

Mike
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1369 Posts
  • 293 Reply Likes
We found the issue pretty quickly.

The radio chooser showed there was still a client connected someplace to the radio. Explains why Tom could oly open 3 panadapters. Once we force disconnected the unknown client everything worked fine.

Dave wo2x
Photo of John - K3MA

John - K3MA

  • 347 Posts
  • 111 Reply Likes
Mike I think you mean section 39.4.1 or at least that is the section in my manual.  One question I have about the quoted statement below that appears earlier in the manual is where can I find the threshold points at which it switches to WIDE?

"Each time one of these thresholds is crossed, either zooming in or out, the noise floor will increase or decrease by about 3 dB. After zooming out to a certain point, the hardware will switch to wideband mode, which causes the radio to open the Bandpass Filters to their maximum bandwidth."
Photo of Michael Walker

Michael Walker, Official Rep

  • 829 Posts
  • 235 Reply Likes
Hi John

I am not sure we have ever published those numbers.  However, you can easily test it yourself by slowing zooming of the panadapter out with only 1 slice active.

You can also be in a WIDE mode if you have 2 slices active on a single SCU and in order for them to work correctly, the BPFs would have to be disabled.

Mike
Photo of Tom W3FRG

Tom W3FRG

  • 86 Posts
  • 17 Reply Likes
Which manual are you seeing these comments of 39.4.1 , user, software ??

Tom