SmartLink and Apple routers (Airport, Time Capsule, etc)

  • 3
  • Idea
  • Updated 4 weeks ago
I just helped a gentleman running an Apple Time Capsule router (same as Airport Extreme with the built in backup drive).

We found out that the Airport routers do not support uPNP. We needed to use manual port forwarding. Here is a pdf which describes how to add port forwarding to the Apple router.
https://www.rainmachine.com/support/portforwarding/Port-Forwarding-Apple-AirPortExtreme-Router-for-HTTPS.pdf

You only need to add one port forwarding rule to the Apple Airport (or Time Capsule) router.

On page 4 of the PDF it shows how to add the port forwarding.. Here are the setting you need to enter.

Description: ​SmartLink
Public UDP Ports: ​ 22000  
Public TCP Ports: ​ 21000   
Private IP Address: ​ <enter the IP  address of the radio>  
Private UDP Port(s): ​ 4993   
Private TCP Port(s): ​ 4994

Click ​ Save​  button> The router will reboot.

Next go into SmartLink Setup and expand Network Settings. Click Manual and enter the following settings 



Click Save then click the test button. You should get a green indicator and if you hover over it (SmartSDR) or click it (Maestro) the bottom section UDP and TCP should show pass.

Dave wo2x
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1061 Posts
  • 214 Reply Likes

Posted 11 months ago

  • 3
Photo of Jay / NO5J

Jay / NO5J

  • 1406 Posts
  • 209 Reply Likes
Dave

Why the choice of ports 22000, and 21000 on the WAN side?

On my Time Capsule,  I port forwarded WAN side TCP 4994 and WAN side UDP 4993, to the LAN side TCP 4994, and UDP 4993 ports. The SmartLink Test Came back with a green indicator after I rebooted the Time Capsule.

Should I change my WAN side port assignments?

     SDRgadgets

#FlexRadio IRC chat

   73, Jay - NO5J

Photo of Jay / NO5J

Jay / NO5J

  • 1406 Posts
  • 209 Reply Likes
Dave
Thanks for the quick reply! I had no particular reason to setup the 1 to 1 pairings I used, and thought I might have overlooked something important.

     SDRgadgets

#FlexRadio IRC chat

   73, Jay - NO5J

Photo of WH6HI - Pat

WH6HI - Pat

  • 263 Posts
  • 36 Reply Likes
I think you also need to enable NAT-PMP also.....
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1061 Posts
  • 214 Reply Likes
It was already enabled. Check the pdf article I lonked to in the above posting. Page 4 I believe.

Dave
Photo of Mark - N7MHB

Mark - N7MHB

  • 38 Posts
  • 10 Reply Likes
You might want to do a DHCP reservation too.
Photo of WH6HI - Pat

WH6HI - Pat

  • 263 Posts
  • 36 Reply Likes
That I dd early on, setting static address for a number different devices.
Photo of Justin - KL2D

Justin - KL2D

  • 85 Posts
  • 36 Reply Likes
Dave - Thanks for posting this, it instantly enabled smartlink for me on my apple airport extreme. I was starting to think it was going to be very complicated but this worked perfectly and was super easy to follow. Thanks again!!!!!
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1061 Posts
  • 214 Reply Likes
Glad it helped! Dave wo2x
Photo of tonyfrg

tonyfrg

  • 1 Post
  • 0 Reply Likes
I'm a new Flex6600 owner and have an Airport Express....this worked great.  Thanks Much - Tony W4TYB
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1061 Posts
  • 214 Reply Likes
You are welcome. Glad it was useful.

73
Dave wo2x