SmartLink and Apple AirPort Extreme Router Setup

  • 2
  • Idea
  • Updated 7 months ago
I am posting the solution I found that may help others, who have a problem setting up SmartLink port forwarding on an Apple AirPort Extreme router. 


The Problem:


On my local LAN, I could launch the AirPort Utility, open the router’s edit menu and program the port forwarding information. But, when I clicked save and update, the router would crash. Restarting the router, by unplugging power for 30 sec and then plugging it back in, revealed that the router did not remember the port forwarding information. Repeated tries yielded the same result.


Googling the problem verified that others also had the same experience, with some having no resolution.


The Solution that worked for me:


Launch SmartSDR and manually program the radio’s IP address to one that is outside the DHCP reservation range of the AirPort router. For example, my router’s DHCP range is from 10.0.1.2 to 10.0.1.99. So, any address above 10.0.1.99 would work. This makes the radio always keep the same Ip address. So, SmartLink always knows where to find it.


Disconnect all of the ethernet cables from the router and unplug power. Physically relocate the router to the location of the computer you use to administer the router.


Plug a single ethernet cable between the Admin computer and one of the router’s LAN ports (not the WAN port).


Launch the Airport Utility and plugin the router power plug. After the router boots up, it should appear on the AirPort Utility graphic window.


Click on the router picture in the AirPort Utility window and a dialog box should appear, with an Edit button in the lower right corner. 


Click the Edit button.


Click Network in the top menu bar.


Under the Port Settings box, Click the “+” box.


In the window that opens enter the following:


Description: FlexRadio (or any description you choose)

Public UDP ports: 4993

Public TCP ports: 4994

Private IP Address: (enter the static IP address of the Flex Radio you programmed above)

Private UDP ports: 4993

Private TCP ports: 4994


Now click Save then Update.


After the router update completes. Reboot the router by unplugging and plugging in the power plug. Then navigate back to the Port Forwarding box and verify that the information you programmed is indeed there.

Return the router to its original physical location and reconnect it to the LAN.


Now launch SmartSDR and in the connection window navigate to SmartLink setup and click “Automatic” and then “Test”. After a short while you should get the green light indication that SmartLink was able to reach the radio on the forwarded ports.



Hope this works for you too.


Clay, AB9A

Photo of Clay

Clay

  • 7 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 2

Be the first to post a reply!