SmartCat Drops TCP Connections From WSJT-X

  • 1
  • Question
  • Updated 6 months ago

I recently set up WSJT-X V1.08 with CAT connections using TCP method. Initially WSJT-X has no trouble connecting and controlling my Flex. I can make contacts, BUT only for a few minutes before that CAT connection is lost. No error message or other indication other than WSJT's ability to control anything is lost. I can get most of the way through a JT-65 QSO, but then it loses control. I've tried resetting settings, changing ports, deleting and adding back in CAT entities in SmartCAT with no success.  No problem with other apps using CAT/TCP.

Any ideas?

Photo of Steve Sterling

Steve Sterling

  • 3 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Dave - WB5NHL

Dave - WB5NHL

  • 264 Posts
  • 60 Reply Likes
I experienced the same problem and had to switch to TS-2000/ COM port approach to get reliable connections to WSJT-X
Photo of Steve Sterling

Steve Sterling

  • 3 Posts
  • 0 Reply Likes
I have about come to the same conclusion. I like the TCP option, less conflict with other apps, but we can make the serial com method work.
Photo of Al K0VM

Al K0VM, Elmer

  • 560 Posts
  • 93 Reply Likes
I am wondering if perhaps your using a TCP  port that is shared with some other app.. The port number can be anything up to 65000 ( i use 26004 ) but the port entered in WSJT must match the port in SSDR CAT.. Try changing them both to something else and restart wsjt and SSDR CAT. 
AL, K0VM
Photo of Steve Sterling

Steve Sterling

  • 3 Posts
  • 0 Reply Likes

Al-- I thought of that too, so had already created a new unique TCP port instance from the 5002 port I already had. The separate didn't help. I think I'm stuck using com port method.


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8698 Posts
  • 3268 Reply Likes
Log a bug report with WSJT-x