Smart SDR Losing Connection - v3.1.8

  • 1
  • Problem
  • Updated 2 weeks ago
This is a new problem for me, since I installed V.3.1.8      Rig is a 6700.

I never had an issue with 3.1.7 or other previous versions,  however, if I leave my PC untended for a while (ie. an hour), my Smart SDR loses connection, closes, and the front panel power button does not respond, requiring I cut power to the radio to be able to start over again.

No, I don't have an issue with Windows power saver settings.. I always leave everything on, all the time.

Anyone else having a new issue like this with V3.1.8     This did not happen to me with v3.1.7 or others.


And NO... I'm not complaining... just hoping to ID a fix.  These last few versions have been great, and have installed without issue, so I am a very happy Flex user.
Photo of Mike Presnell

Mike Presnell

  • 53 Posts
  • 18 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Bill W2PKY

Bill W2PKY

  • 540 Posts
  • 94 Reply Likes
Hello Mike-
Would be helpful to know your network & PC setup. Have you looked at the Event Viewer for possible errors?  
Photo of Mike Presnell

Mike Presnell

  • 53 Posts
  • 18 Reply Likes
Bill,
RR..

PC is running Windows 10 with all the current updates.  PC is connected to my router wirelessly (I prefer to isolate my PC for lightning events).    The PC has an i7 4790, and 16GB of RAM. 

 The Flex 6700 is connected to my Router via a 24 Port Gigabyte Switch.  

Good idea to check the event viewer... but I don't really know what I'm looking for there. 
Photo of Bill W2PKY

Bill W2PKY

  • 540 Posts
  • 94 Reply Likes
Hello Mike-

May want to save your profiles and do a reset on the radio and see if the problem goes away.

Because your PC is connected to the radio wirelessly through the router there is always a chance the data stream can be interrupted for unspecified periods of time. 

Check the Wifi & Ethernet Adapters for power management settings.
In the event viewer got to windows logs > Application to see if there are any red errors that might give a clue right after a crash.
The problem you are experiencing is usually caused by an interruption in the network circuit. 
(Edited)
Photo of Joseph

Joseph

  • 29 Posts
  • 5 Reply Likes
Mike, I had a similar experience with the latest update.  My rig is a 6600m with SmartSDR on an 8 core 3.1Ghz Dell desktop with Windows 10 (latest build) and lots of RAM.

1. Started the radio update.
2. Downloaded and installed the SmartSDR update (3.1.8). Restarted the machine.
3. Restarted the radio and it looked and acted normally from the front panel.
4.  Started SmartSDR...looked normal acted normal, BUT...
5.  ...SSDR started with two slices, A and B, but neither of them were tied to the one showing on the radio!  I started a third slice, C, but SSDR would not open a fourth because I am guessing the one running on the radio, which had no letter where the slice identifier should be, was a legit slice as well.
6.  I closed the B and C slices.  Slice A looked normal on the SSDR and the no-name slice acted normally, although independently, on the radio.  It was in Smart Control mode at the time.
7. Rebooted everything.  This time everything looked like you would expect and Smart Control was working, BUT...
8.  ...a few minutes later I tried the radio front panel and it was frozen.  Not in sync with the SSDR display, couldn't change freq, nada.
9. Rebooted everything yet again (had to cycle the power on the 6600m) and everything came up normally.  And stayed that way.  So far...

I am more or less familiar with this behavior for a Flex update so it no longer drives me crazy.  Just keep resetting everything and sooner or later it starts to work for no apparent reason.

Hang in there!!
Photo of Chris DL5NAM

Chris DL5NAM

  • 680 Posts
  • 154 Reply Likes
WIFI or LAN ?
Photo of Joseph

Joseph

  • 29 Posts
  • 5 Reply Likes
LAN