Smart SDR losing connection to radio

  • 1
  • Problem
  • Updated 3 months ago
This is the third time now with version 2.3.7 that I get the message Smart SDR lost connection to radio. When you click on OK to restart it does not see radio on network. Also volume will go full bore wide open. Have to reboot to get back to normal.
Photo of KK9W - Steve

KK9W - Steve

  • 632 Posts
  • 189 Reply Likes

Posted 3 months ago

  • 1
Photo of N7IPY

N7IPY

  • 10 Posts
  • 1 Reply Like
Steve - I'm running v2.2.8 right now and my 6400 disconnects every night, sometime after I have gone to bed.  The computer is a dedicated NUC i5 based system running win7 Pro.  Everything else works perfectly for me but the 6400 drops the link (or NUC) every night.  I don't turn off the environment when not in use; the 6400 is a Radio Server and I think meant to be left on all the time.  I have tried disableing the power saving modes around the network hardware but problem continues.
Restarting SmartSDR and connecting to the radio and all is fine for the rest of the day.  Not a big problem.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
If the network adapter on the NUC is configured to be controlled by Power Management, that can cause a disconnect.
Photo of KK9W - Steve

KK9W - Steve

  • 632 Posts
  • 189 Reply Likes
I'll check that Tim.
N7IPY . . . It is a problem if you are in the middle of a QSO or on a net or Running a net.
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 268 Posts
  • 66 Reply Likes
I also am having disconnects with 2.3.7.  The radio (a 6700) then needs a long button press to force a shutdown.  After the radio restarts, all is well again.  This has happened twice.  With 2.2.8, I did not have this problem.  There have been no other changes in my system (3.7GHz i7-8700K, Windows 10 Pro).
I am feeding spots from DXLab's Commander.
(Edited)
Photo of Gene - K3GC

Gene - K3GC

  • 206 Posts
  • 34 Reply Likes
My rig is essentially like yours and I have had one disconnect; also required a long button press.
Photo of Gene - K3GC

Gene - K3GC

  • 206 Posts
  • 34 Reply Likes
It just happened to me a second time in an hour.
Earlier I was playing with power settings to see if sleep mode was feasible (it isn't).  I have completely disabled sleep now.
The disconnects were not in sleep  mode.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
The PC does not necessarily need to be in sleep mode to power down individual hardware.  You should disable it at the adapter level if it supports power management.

Also if the adapter properties have an option for Green Ethernet, disable it.

https://helpdesk.flexradio.com/hc/en-us/articles/202118518-Optimizing-Ethernet-Adapter-Settings-for-...
Photo of KK9W - Steve

KK9W - Steve

  • 632 Posts
  • 189 Reply Likes
Went through that and it's been staying connected. Thanks for your as usual brillant answers. Enjoy your weekend!!!
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
You're welcome.
Photo of KK9W - Steve

KK9W - Steve

  • 632 Posts
  • 189 Reply Likes
My issue appears to be my USB hub is going bad. Flex knob started doing funky stuff also. Replaced and so far all is well.