Smart SDR 1.4.0 Locks / Freezes Up

  • 2
  • Problem
  • Updated 5 years ago

Since I installed Smart SDR 1.4.0, I'm noticing intermittent freezes / lock ups of the Smart SDR 1.4.0 software.  Windows Vista Home Premium (64 bit) w Service Pack 2 and all current updates.  Clock at bottom right continues to run but audio is dead, waterfall/panadapter stops.  Menus at top of screen continue to operate File | Settings | Profiles | Help but submenus may or may not work depending upon which one is clicked.

Closing SmartSDR then relaunching results in radio's status showing up as "in use". Recovering usually involves turning off the radio

No changes have been made to hardware or software used on the PC.  Have run various versions of SmartSDR on this same PC without any issues.

All of the PC programs as well as the PC itself continue operate normally.

The PC is a HP Pavilion Core 2 Quad 2.33 gHz Processor with 8GB RAM.

Disabling TrendMicro Antivirus does not make any difference.

Any thoughts on what to check?  Thank you.

Gary, AK4ZX
Chattanooga, TN
Photo of Gary S Ownsby

Gary S Ownsby

  • 25 Posts
  • 4 Reply Likes

Posted 5 years ago

  • 2
Photo of Larry - W8LLL

Larry - W8LLL

  • 532 Posts
  • 116 Reply Likes
Photo of Rhett Aultman

Rhett Aultman

  • 31 Posts
  • 9 Reply Likes
This might sound like one of those "did you try turning it off and back on" things, but I had this problem, and it turned out the root cause was that I still had Smart SDR 1.3.8 and its related software still intalled.  I removed it, rebooted, and have never again seen the problem.
Photo of Gary S Ownsby

Gary S Ownsby

  • 25 Posts
  • 4 Reply Likes
Larry, Rhett:

Thanks for the quick replies.  I just noticed that Flex has released version SmartSDR V1.4.3.  I've installed it.  I hope it will cure the problem.

Rhett:  Yes, I tried turning it off and on and everything else I could think of but nothing really helped.  Sometimes the "in use" status continued after a power down and a PC restart.  Pesky problem!

Thanks again!

Photo of Duane, AC5AA

Duane, AC5AA

  • 467 Posts
  • 107 Reply Likes
Gary - see Larry's link above and see the recommendation to DISABLE any unused DAX channels.  This means to open the DAX control panel and disable it there.  I found that this appears to be a workaround for me until they get the problem solved.  (It happens in 1.4 and 1.4.3 as well on my 6500.)
Photo of Ross - K9COX

Ross - K9COX

  • 353 Posts
  • 108 Reply Likes
I'll bet you will be pleased with 1.4.3
Photo of Gary S Ownsby

Gary S Ownsby

  • 25 Posts
  • 4 Reply Likes
Duane, Ross:

Thanks for the suggestion and encouraging comment.

1.4.3 is working flawlessly so far.  I've also installed it on one of my older Toshiba laptops and now can remotely (through my local network) operate the Flex.  I upgraded my home network a year or so ago to 1GB+ speed so the Flex and 1.4.3 are zooming along perfectly.  Latency is practically nonexistent so far even when I'm using my older laptop for email and surfing while listening.

As soon as the monsoon gets out of here, I'm headed out to the deck to operate "remote".

Thanks again.

Photo of DrTeeth


  • 1687 Posts
  • 389 Reply Likes
I have had the issue with 1.4.3 and I have disabled all unused DAX channels too. Not too frequent at all, but still happens.
Photo of Steve Gw0gei

Steve Gw0gei

  • 193 Posts
  • 50 Reply Likes
I have had the same issue with 1.4 and 1.43 - always requires a reboot of the radio in the shack so I have given up on remote monitoring from elsewhere in the house for now. Even after my fast work laptop is turned off the shack laptop on cat 5 wired connection stills sees the radio as in use by the PC that has been switched off.