Smart Cat 1.6.17 Com port problems

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Unable to create new com port and com port 4 has an error.

Have uninstalled and Cat, Dax and SmartSDR 1.6.17 re booted pc and radio and reinstalled.  Still getting the same error.  Unable to add any new cat ports.

Windows 10
6500





Steve
KD7IQL
Photo of Steven Cook

Steven Cook

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Hi Steve,
I use DDUtil, SDR-Bridge and CW Skimmer and everything is working fine.  So I didn't look at CAT until reading your message.  Also running on Win10 and my PC uses a solid state drive.  

I have a similar error here but on 9 /19 pair and 10/20 pair.  If you "hover" over the "error" button you may get the same message:




I get the same messages in device manager.  





But I noticed COM9 appears twice in the port list.  Which is different that your scenario







Using the log option the test function is working and communicating with the radio.  Freq data it returned from the radio




It doesn't appear that I'm using Com9 or Com10 (i.e. no log data displayed).   I do see log data on the TCP port for DDUTil . 

Again, none of this is affecting the operation that I can tell but I'd like to fix it eventually.  I only operate CW so I haven't tried adding more COM ports.

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10 
Photo of Steve - KD8QWT

Steve - KD8QWT

  • 74 Posts
  • 14 Reply Likes
I had the same issue.  I uninstalled SSDR and rebooted before installing 1.6.  I think the SSDR uninstaller did not remove the Flex VSP driver.  Once I uninstalled the Flex VSP driver, rebooted, and re-installed it, CAT started working.

It's typically located here
C:\Program Files\FlexRadio Systems\SmartSDR v1.6.17\64-bit Drivers\VSP
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
If those ports were imported into the new 1.6 left over from 1.5, it may help to delete them using the CAT application and recreate them. If that doesn't help, check device manager and tell it to show all hidden ports/devices. You might have a phantom port left over that didn't get deleted correctly.

I had this problem and a delete and re-install fixed it. It created a port 9/109 combo that I could the. define as my Winkey port.

Ken - NM9P
6500
V.1.6.17
Win 10
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
Ken is on the right track.  These are ports from 1.5 that for some reason did not get converted properly for some reason.  You can try removing teh ports using this HD article: https://helpdesk.flexradio.com/hc/en-us/articles/200883925-Removing-Hidden-or-Ghosted-Com-ports

Remove the "ghosted" and all other FlexRadio ports.  Then reboot the PC and re-add them
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Hi Tim & Ken,
UPDATE -- In my case I deleted COM9 and COM10 using the new CAT program.   The corresponding ports in device manager vanished.  The only remaining port currently is the TCP port. 



At that point (and without rebooting yet)  I started up DDUTil and SSDR and SDR-Bridge and CWS.

All are working fine with only the TCP port.



I don't appear to need the serial ports.  

I thought it would be a good test to see if I could recreate one anyway.  I get the error below but I haven't rebooted the PC yet so could be it.



Will try rebooting later to see if that makes a difference.  Any other tips?

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
I make it a habit always to reboot after monkeying with serial ports and audio ports through device manager, etc.
it may not be necessary, but it couldn't hurt!

You may still have some phantom ports hiding in the background. Look for Tim's post about removing them. It has saved my bacon several times.

I'll defer to Tim for any other comment.
Photo of Steve Cook

Steve Cook

  • 15 Posts
  • 0 Reply Likes
Thanks I will try when I get home
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
UPDATE -- tried rebooting, tried deleting hidden VSP ports using the commands noted above, rebooted a few more times.  Stopped and restarted CAT, repeated process, rebooted....

Get the same error as before when trying to create a new port.




I don't seem to need a serial port so this is not a show stopper.  

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Mark Erbaugh

Mark Erbaugh

  • 512 Posts
  • 43 Reply Likes
I got the same message (has COM# open which is needed by this port) when I upgraded. This may have been a severe solution, but I uninstalled the FlexVSP. That broke CAT and it recommended reinstalling SSDR, which I uninstalled and reinstalled and it fixed things.
Photo of Steve - KD8QWT

Steve - KD8QWT

  • 74 Posts
  • 14 Reply Likes
Same here, only I didn't uninstall SSDR when it recommended to do so.  I just rebooted and reinstalled Flex VSP. 
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Steve,
What was the process you used to reinstall Flex VSP?

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Steve - KD8QWT

Steve - KD8QWT

  • 74 Posts
  • 14 Reply Likes
I posted it several comments up.  Just run the exe in the VSP directory.  If you uninstalled the Flex VSP, reboot the PC before installing it again.  Expect no messages after running it, whether it worked or not.

It's typically located here
C:\Program Files\FlexRadio Systems\SmartSDR v1.6.17\64-bit Drivers\VSP
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
You have ghosted com ports that are causing problems.  Removing them is easier and safer than uninstalling the FlexVSP driver, which as port of the uninstall, removes all FlexVSP ports.  Use this procedure to get rid of ghosted com ports.  https://helpdesk.flexradio.com/hc/en-us/articles/200883925-Removing-Hidden-or-Ghosted-Com-ports
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Steve & Tim,
UPDATE -- There didn't appear to be any ghosted com ports in my case.  

Here is what I did that worked.  Basically it is what Steve suggested. 

Stopped all Flex related programs CAT, SSDR, DDUtil, etc 

Using control panel, I removed VSP V1.0.1  (unless I wrote it down wrong, this  looks like it may be the old version? )

Rebooted the PC

Re-installed the driver, using this link since my PC is  Win10 64 bit.
 C:\Program Files\FlexRadio Systems\SmartSDR v1.6.17\64-bit Drivers\VSP

Noticed the version is now 1.0.2



Started up CAT and added a port Com10 / 110

No errors, started up all of my Flex related software (DDUtil, SSDR, SDR-Bridge, CW skimmer)
 and everything seems to work,

Then did a test on the new CAT port Com10 using the LOG option and tested using FA;.  Freq date returned as expected.







Steve,
You can want to check the version of your FlexVSP to see if it is the old or new version.



Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10

 
Photo of Steve - KD8QWT

Steve - KD8QWT

  • 74 Posts
  • 14 Reply Likes
I've always uninstalled SSDR prior to installing a new version.  I even removed any stray directories.  I have no idea what version of VSP was installed before.  I've run into VSP strangeness before, so this isn't the first time I've had to manually remove and reinstall.  I'm 100% sure it's the new one now.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
Ahhhhh.  Now that is interesting.  We did a FlexVSP update a long time ago.  It was not an automatic upgrade; it required a manual uninstall prior to installing SmartSDR to get it updated.  I suspect you may have inadvertently missed that.  Thanks for letting me know this happened.  I'll see if there is a way to trap this condition.  Thanks Al.
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Tim,
That could be the scenario.  I have been doing my SSDR updates without un-installing the previous version.  As long as I keep my shortcuts straight there has never been a problem.  So I would have missed any VSP update that required an un-install.

There may be others with this same process.  So if my notation on the version numbers is correct it is easy to detect and fix.

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
Tim,
I tried searching for the correct version number of FlexVSP in the changelog and release notes.  

I wanted to see if my guess about the new version being  1.0.2 is correct and that the previous version was 1.0.1

Can you point me to where the VSP versions are documented or confirm my assumptions?

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW.................... V 1.6.17.74
SSDR / DAX / CAT...... V 1.6.17.156
Win10




Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
1.0.2 is the latest version.  It is best to handle this as part of the installation process.  I just wrote up a defect report on it.
Photo of Steve Cook

Steve Cook

  • 15 Posts
  • 0 Reply Likes
Official Response
I removed a ghosted com port.  Then uninstall Flex VSP 1.0.2. Rebooted the PC.  I was able to successfully install cat V 1.6.17.  No errors 

This conversation is no longer open for comments or replies.