Should I Unregister then Reregister to fix router problem?

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Upgraded to SSDR 2.0 yesterday, and successfully registered, but was running an Apple Airport that was a bit flaky.  Decided to upgrade to a LINKSYS AC5400, which has UPNP, and is the very latest technology.  Now SSDR says it successfully registered, but both TCP and UDP say "FAIL".  I have a feeling that I should UNREGISTER and then REREGISTER to solve this.  Comments?  
Photo of K0UNX

K0UNX

  • 107 Posts
  • 30 Reply Likes

Posted 2 years ago

  • 1
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1668 Posts
  • 613 Reply Likes
I suspect the answer to your question is “no.” Looks like you need to check your router and network configuration first.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Check that either UpNP is activated, or that you have manually forwarded the two required ports.

Then go to the screen in the radio chooser where you can select either Automatic or Manual.

If UPNP is activated on your new router, then hit "Automatic." Wait a few seconds, and hit the test button.

If UPNP is not activated, and you want to use UPNP, then Open the router config and turn UPNP on. On your ASUS router, it should be located on your Advanced>WAN tab.

Be sure to hit "apply" on the router. You may even need to restart the router.. it may be called "reboot" on yours.

If you would rather manually forward the ports, hit "Manual" on the rig configuration, and note the two ports that it says to forward and open the router configuration page and set them. Then hit "apply" on the router, wait until it is finished, and then hit "test" on the rig.

If that doesn't work, then you may have some additional router or network configuration issues. Post your results and someone can probably talk you through it.

Ken - NM9P
(Edited)
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Sorry... wrote this while distracted...thought I read ASUS, which is what I have...please disregard the how-to for setting up UPNP.

Ria is a networking expert. And should get you straightened out.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2314 Posts
  • 956 Reply Likes
Did you enable UPnP? If that doesn't work, did you try manual port forwarding? Dave, WO2X has an instructional video on Apple routers which don't have UPnP. You may want to look at that.
(Edited)
Photo of K0UNX

K0UNX

  • 107 Posts
  • 30 Reply Likes
Yes, it is enabled.  I'm now using the Linksys AC5400 and just double-checked it.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
If UPnP indicates a PASS, then regardless of the other statuses, you are good to go.  Only one network method has to PASS.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1453 Posts
  • 309 Reply Likes
Tim is correct.

For uPNP the upper section should have apss for TCP and UDP. The bottom section doesn't matter at that point. Just make sure your radio is set for automatic under Network Settings in the SmartLink setup in SmartSDR/Maestro.

BTW, I posted instructions to get the Airport routers working with SmartLink in a separate post. The Apple routers do not appear to properly support uPNP and must be set up for manual port forwarding.

Dave wo2x
Photo of K0UNX

K0UNX

  • 107 Posts
  • 30 Reply Likes
This isn't the Apple router.  I deep-sixed that one and am using a brand new Linksys.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1453 Posts
  • 309 Reply Likes
Yes, just mentioned if you wanted to go back to the Apple.

As Tim said, if you see pass for both UDP and TCP in the uPNP section you are good to go.

Dave wo2x
Photo of K0UNX

K0UNX

  • 107 Posts
  • 30 Reply Likes
Somehow, the radio is telling the Flex server that is is on the wrong subnet.  I just have one router here, and the COMPUTER is on 192.168.1.116, but the RADIO is reporting that it is on 192.168.7.53.  That is on the wrong subnet.  The computer is talking to the radio, but when I try to use Smartlink, i guess that the Smartlink server thinks the radio is on a nonexistent subnet.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Tim gets the cigar for hitting the bullseye!

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
And this is after only having 6 hrs of sleep in the last 48 hrs.  Imagine if I could get my full beauty sleep.  I'd be on FIRE!
(Edited)
Photo of Richard McClelland, AA5S

Richard McClelland, AA5S

  • 296 Posts
  • 61 Reply Likes
Eat a handful of amphetamines and you should be good for another 48 hours or so.  Your hair will turn into snakes, though, so watch out for that.  '
Photo of K0UNX

K0UNX

  • 107 Posts
  • 30 Reply Likes
Just a postscript here to say that I've solved the problem of having my WIRED network co-exist with the WIRELESS network.  Eero provides a nice app for monitoring and configuring their network.  I used the app to go from DHCP to BRIDGE mode, and now my router assigns ALL the addresses.  All is good here again.

So I'd really like to take this opportunity to once again thank ALL of you who helped diagnose this sticky problem!
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1453 Posts
  • 309 Reply Likes
Glad you got it all working! Now go play radio.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9188 Posts
  • 3550 Reply Likes
Official Response
You may have 2 DHCP servers on your network (not a good thing)
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 897 Posts
  • 342 Reply Likes
To answer the thread title question, the only problem that would be fixed by unregistering/re-registering the radio is with which account to associate the radio.  This is completely separate from connection issues which is what the Test button gives some visibility.  Connection issues usually point to network related issues that must be resolved in your local network configuration (radio side network, not the client side remote network).