setup wsjt-x 1.7 with 1.10.8

  • 1
  • Question
  • Updated 8 months ago
  • Answered
WSJT-X 1.7 looks like it is looking for an IP address for Flex6xxx.  All of the posts I can find in the community refer to older software and refer to setting up the Flex as if it was a TS-2000.  When I plug in the IP address from the radio setup panel I get an "I/O error" message.  Works fine with Commaner as middleware with the same IP address.  This may be more of a WSJT-X question but/and if anybody in the Flex community can direct me in the proper direction - much appreciated

John.
Photo of John K4SQC

John K4SQC

  • 25 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3700 Posts
  • 1550 Reply Likes

You need to NOT ONLY give it an IP address but ALSO a PORT NUMBER


So if your Flex RADIO is 192.168.30.121

you need to go into SmartCAT and create a CAT Port at say 5004



Then the correct IP would be 192.168.30.121:5004


You can also key the radio XMT via that same CAT port .. no need for PTT port

(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
Mario is 100% correct.  
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 64 Posts
  • 24 Reply Likes
Official Response
Just a small correction: it is not the IP address of the RADIO but the IP address of the PC where SmartCAT is running.. If WSJT-X is on the same PC it would be localhost:5004 or 127.0.0.1:5004

73, Mario
Photo of David Warnberg

David Warnberg

  • 581 Posts
  • 63 Reply Likes
I'd suggest you use the loopback IP (127.0.0.1) rather then localhost, I've seen issues where "localhost" wont resolve, yes silly I know.... 
Photo of Harry Williams

Harry Williams

  • 112 Posts
  • 8 Reply Likes
I have wsjt-x configured using the TS2000 setting and a comport pair to the 6700. Is there some advantage using Flex6000 setting and a TCP port?

73,
Harry
W0LS
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
You are not using CAT over a virtual serial port.
Photo of Harry Williams

Harry Williams

  • 112 Posts
  • 8 Reply Likes
Thanks for response...I assume by that your saying a TCP port is a better choice than a VSP...
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
Yes, you can infer that ;-)

The TCP/IP stack in the Windows operating system is a native protocol.  The virtual com port is not.  Also, socket programming is much easier (and possibly reliable) than data handling with serial ports in Windows (the MS SerialPort methods leave a lot to be desired).  I prefer network communications over serial when it is an option.
Photo of Harry Williams

Harry Williams

  • 112 Posts
  • 8 Reply Likes
Excellent comment and thanks for including some more meat!

Harry
W0LS
Photo of W2PP

W2PP

  • 310 Posts
  • 45 Reply Likes
Actually ists localhost:5002, or whatever your SDR is set to.
Peter
Photo of W5AP

W5AP

  • 85 Posts
  • 6 Reply Likes
Please show a picture of the WXJT-X setup for Radio
and SmartSDR CAT

I've tried all kinds of Network Servers with nothing working.
What goes in the Network Server box and PTT Method under the Radio tab?
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1317 Posts
  • 279 Reply Likes
Here you go!

Dave wo2x
Photo of W5AP

W5AP

  • 85 Posts
  • 6 Reply Likes
I finally got my WSJT-X to run FT8 by creating a TCP Port 5002 in SmartSDR CAT
and setting the WSJT-X Radio settings to Rig;FlexRadio 6xxx, Network Server to localhost:5002, and PTT Method to RTS then select Com10 (an unused Serial Port in SmartSDR CAT) then select the button CAT and SHUTDOWN THE WSJT-X program and restart. Test CAT and PTT
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1317 Posts
  • 279 Reply Likes
5002 is used by DDUtil. If you do not plan to use DDUtil then you are OK but if you want to use DDUtil in the future you will need to create a different TCP port as per my example above.

Dave wo2x