SDRBridge and SkimmerServer

  • 1
  • Question
  • Updated 4 years ago
I've been pulling my hair out on this one.  A couple of weeks ago everything was working fine with RTTYSkimmerServer.  Sure, I had to restart it a couple of times until the GUI came up and restart DAX a couple of times until I saw the CPU usage increase along with the number of decoders, it worked and worked well.  Last week I added CWSkimmer and SkimmerServer to the mix and they worked well too.

Now, fast forward to last night... I tried to get RTTYSkimmerServer running again and was unsuccessful. Then I noticed that CWSkimmerServer was no longer working either. This lead to an upgrade to SDRBridge 1.5 and SmartSDR 1.6.21, numerous reboots of the 6500 and the PC (Win7, btw), reinstalls of all skimmer software and DAX and still, no luck.    

Oddly CWSkimmer when launched from SDRBridge works just fine.  It's also obvious the server variants are taking over the IQ channels because CWSkimmer's waterfall doesnt show any data until I kill the server and it takes over.  When a server is running it's clearly in control of the panadapter too.  It will change the center frequency and recenter if manually adjusted.

One of the problems I've seen in the past was that when RTTYSkimmerServer was not working properly, it's "band scope" feature wouldnt show any data at all.  But after a restart or jiggle or a toggle of the DAX setting, it would show data and start spotting.  Now, none of that helps.

Another oddity is that when I shut down DAX I get the warning about other programs that might be using the data.  As soon as I dismiss the dialog what looks like an error dialog pops up for less than a second.  I'd like to see what it has to say.  It might be a clue. Does that sort of thing get logged anywhere?  Is anyone else running the skimmer servers with 1.5 and 1.6.21?
Photo of K1DBO

K1DBO

  • 543 Posts
  • 112 Reply Likes

Posted 4 years ago

  • 1
Photo of Ed - W2RF

Ed - W2RF

  • 258 Posts
  • 77 Reply Likes
The Server activation problem has been fixed in v1.5.1, which is available for download at http://www.qrv.com/sdrbridge. The new version also does not require a restart when reconfiguring knobs.

73 Ed W2RF