SDR CAT

  • 1
  • Problem
  • Updated 1 month ago
When I started up my 6600M today, my usual CAT settings were all missing and only showed a TCP port 5002 and a Slice A Cat port 4.   I don't know where they went, but can my previous settings (I had about 10 CAT settings for 2 slices, 2 PTT, OTSPR, Winkey, and other devices such as PST rotor control of my SteppIR)   but the question is can my previous settings be restored. I dont know where they may be saved or why they went away.
Photo of W5AP

W5AP

  • 81 Posts
  • 6 Reply Likes

Posted 1 month ago

  • 1
Photo of Joe N3HEE

Joe N3HEE

  • 210 Posts
  • 36 Reply Likes

Sounds like the FlexVSP driver did not load properly.  Try rebooting computer and radio first. I'm not aware of a way to restore those settings ? 
Photo of Joe N3HEE

Joe N3HEE

  • 210 Posts
  • 36 Reply Likes
From the manual....

When SmartSDR CAT starts the first time, it will create a Serial CAT port automatically at the lowest open port (COM4 or above) and a TCP CAT Port on port 5002 primarily for DDUtil compatibility.

If the FlexVSP driver is not loaded or has not fully started at the time the SmartSDR CAT user interface starts, an error message will be displayed. This condition in which the VSP driver has not fully started can exist on systems that utilize a solid state hard drive allowing Windows to run the Startup applications before the FlexVSP service has started. If this occurs, wait 15-30 seconds and then manually restart SmartSDR CAT.


Photo of Gayle Lawson

Gayle Lawson

  • 17 Posts
  • 2 Reply Likes
I shut down about midnight, the dreaded Win 10 "Installing Updates" window  popped up.  Win 10 could have gotten you.  I'm working OK this morning.

Gayle K0FLY
Photo of W5AP

W5AP

  • 81 Posts
  • 6 Reply Likes
My solution was to remove SmartSDR per Tim's instructions, remove all ghosted ports, etc. and re-install 2.4.9.  Then rebuild the DAX channels for all mydevices, N1MM etc.  Tedious but all working now.  I wish there was a way to save all the DAX settings to re-load should this happen again.   My only glitch is that IQ stream 2 shows ree (driver error). So I may have to revisit. Although the band scope for slice B (slice 2) shows the correct frequencies and follows slice band movements in N1MM.
Photo of W5AP

W5AP

  • 81 Posts
  • 6 Reply Likes
My solution was to remove SmartSDR per Tim's instructions, remove all ghosted ports,etc. then re-install SmartSDR  Then re-install the DAX ports as before and re-connect to devices and well as set up N1MM ports to correspond. Pretty tedious, but all working now except IQ 2 shows red(driver error) although the band scope in N1MM tracks perfectly.  
Photo of Joe N3HEE

Joe N3HEE

  • 210 Posts
  • 36 Reply Likes

I had the same issue after Win 1809 update.  That error is probably due to a DAX driver being mislabled.  See this thread for help.

https://community.flexradio.com/flexradio/topics/most-common-fix-for-dax-driver-errors-in-windows-sp...
Photo of W5AP

W5AP

  • 81 Posts
  • 6 Reply Likes
tnx es 73, that is extremely helpful....Jim