SDR 2.5.1 SmartSDR Auto Connect:

  • 1
  • Question
  • Updated 1 week ago
  • Acknowledged
I can't seem to get SSDR 2.5.1 SmartSDR Auto Connect to work.  I have it turned on in the Settings option but it still wants me to select my (only) radio.  My assumption is that when I click the SSDR icon, I would go directly to SSDR attached to my 6300.  Is this a wrong assumption?
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 8 Reply Likes

Posted 1 week ago

  • 1
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 47 Posts
  • 15 Reply Likes
Ken,

After setting the autoconnect option, the radio must be selected once.  After closing and starting SmartSDR the next time, I'd expect it to autoconnect.

There are certain conditions where autoconnect won't work, including if the the radio requires a firmware update.
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 8 Reply Likes
Yes, that's what I would expect also but it doesn't work.  Just gives me the normal selection screen and I have to connect to my radio as always.
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 47 Posts
  • 15 Reply Likes
Ken, are you running your radio over SmartLink?  Or is on a local network?
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 8 Reply Likes
Hi.  It's on a local network (although I do ocasionally run via Smartlink)
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 8 Reply Likes
Abed,  Have you tested this in the actual release?  Still can't get it working.
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 47 Posts
  • 15 Reply Likes
Ken,

I have tried autostart on a 6300, and you are correct that it does not work.  It is working on v3 but it does not work with v2.5.1.

I have added this as #7573, and our engineering team already has already looked into this and have fixed it.  The fix will be in the next release.
Photo of Terry K8EET

Terry K8EET

  • 124 Posts
  • 15 Reply Likes
I am also having an issue (first time I've had an issue updating) When I select Smart SDR, I have two windows come up one says, disconnect the other says connect. The one that says connect is labeled SMART SDR CAT and clicking connect opens the CAT and DAX windows closes without bringing up Smart SDR leaving the other Smart SDR Disconnect panel open. Clicking Disconnect opens up a new smaller window it says Connected Stations SmartSDR-M: FLEX-6600M with a button saying Disconnect Station, does bring up SDR but then the CAT and DAX windows says, "Station FLEX is not connected. Start FLEX-6600M or choose another station from the list."
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 47 Posts
  • 15 Reply Likes
Terry,

When you opened SmartSDR, it sounds like it had both a "Connect" and a "Disconnect..." button.  If you press "Connect" both SmartSDR on your PC and the front panel of your FLEX-6600M would be operational simultaneously.  This is the multiFLEX feature.

When you use CAT and DAX, you can select which station you want them to be connected to-- it sounds like you previously had it connected to your 6600M front panel.  If you started SmartSDR on your PC, you could connect CAT and DAX to SmartSDR on your PC instead.

If you want to use CAT and DAX with your 6600M front panel, simply start your front panel again (press the Operate button). 
Photo of Terry K8EET

Terry K8EET

  • 124 Posts
  • 15 Reply Likes
I have started it from the front panel several times. Sometimes I can get SDR working...(but when it opens the DAX and CAT screens close.) I even (probably a mistake) deleted older versions of the program thinking there was something from a previous version messing it up. 

When I'm back on the Flex I have the DAX and CAT panels open vs. 2.5.1. Showing Station FLEX-6600M. However, I don't have any IQ Streaming. It says I have No Panadapter but I do. I also have a DAX channel open for Slice A and show RX streaming from Slice A.

The Device Manager shows correct settings for Audio inputs and outputs.
Photo of Gary Keating

Gary Keating

  • 1 Post
  • 0 Reply Likes
Auto Connect is not working for me either. V2.5.1. I have auto connect selected in Settings and have manually selected it several times and rebooted the computer a couple of times but it still wants me to select my 6700 each time I start SmartSDR.
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 47 Posts
  • 15 Reply Likes
Official Response
We have verified that autoconnect works with v3.0.27 but not with v2.5.1.

This has been entered into our system and our engineering team has fixed the issue for the next public release.