rtty split in fldigi

  • 1
  • Question
  • Updated 2 years ago
This evening I tried working AN400I on RTTY. He was working split. In SSDR I set slice A to the receive frequency and slice B to TX making sure TX was set in the flag. This is how I work CW splits.

As soon as I tried to respond TX moved to slice A and I was transmitting on his frequency.

What did I miss? Why is TX swapping back to Slice A after I select Slice B?
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes

Posted 2 years ago

  • 1
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
I just posted to the fldigi group but still hoping someone here knows the solution.
Photo of Rob Fissel

Rob Fissel

  • 270 Posts
  • 47 Reply Likes
FLdigi, AFAIK, doesn't allow the use of multiple VFO's on one single instance of the software running. You have two options that I know of:

Use XIT to work split. 

Use two instances of FLdigi, with one configured to a CAT port assigned to slice A in SmartCAT, and the other instance of FLdigi using a CAT port assigned to slice B. 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3454 Reply Likes
Did you look in the Fldigi manual?

There is a certain way to work split using Fldigi regardless of the radio used.  Fldigi allows you to set different RX and TX frequencies.  As per the Fldigi manual, you do the following:

  • select the TX freq and press the ‘Lck’ button – this fixes the TX
  • clicking anywhere on the waterfall after you’ve pressed Lck now sets the receive frequency

Don’t forget to unclick Lck when you’re done.

There is another way to do it and that is by using the XIT feature of SmartSDR to change your TX frequency to where the split station is listening.

If you are trying to use two slices, like what is done with phone and CW, that becomes problematic because each slice must be running it own instance of Fldigi and they are not synchronized.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
I guess I was hoping it was just an old hack and not the way things are today.

The problem I have with that method is that you are locking your transmit frequency, not your receive frequency. I don't know about others but I'll move my transmit around to try and follow where I think the DX will be answering.

The other problem is that it all has to fit on fldigi's rather narrow waterfall. I would really call this split. More like RIT.

How about N1MM+. What are the options there? I haven't tried split RTTY as I thought it would be easy with fldigi.

Kev
Photo of Eric - KE5DTO

Eric - KE5DTO, Employee

  • 673 Posts
  • 203 Reply Likes
Be aware that if you are keying via a CAT or PTT port, you have the option of having that port switch the transmit Slice to the associated one with the port.  If you don't want this behavior, you can turn this off by editing the CAT port and unchecking the Auto Switch TX option.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
In fldigi RigCAT I'm using CAT command for PTT. The device is set to COM4. in SmartSDR CAT COM4 is set to Auto Switch TX. I unset it and I think that did it! For a test I have receive at 7.070 and transmit at 7.080. At least according to SmartSDR it transmitted where I expected it to transmit.

Thanks!
Photo of Pete - W6OP

Pete - W6OP

  • 21 Posts
  • 8 Reply Likes
I am confused by what everyone is saying about running split. I have fldigi configured to use slice B and B is selected as the transmit slice. Seems to transmit on Slice B just fine. I also have a slice A and feed the receive audio (DAX) on slice A to fldgi. Shows the signals and decodes and all. What am I missing in this discussion.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Hi Pete... I haven't retried this scenario in quite a while but I think it was resolved by turning on (or off) the Auto Switch TX in SmartSDR CAT as mentioned in Eric's post above. 

Kev