Router Setup for SmartSDR Remote Operation Using SmartSDR iOS

  • 2
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I've almost got everything working between my iPhone remotely back to the FLEX-6500 station. Everything works fine as long as I am within range of my own Wi-Fi. I am down to just needing to get the Port Forwarding set up in the router for WAN operations.

- In layman's' terms, what EXACTLY do I put in the router?
- Do I use the 192.168.1.XXX address locally for the radio or the computer?
- Or do I use the "external" IP Address like 74.62.XXX.YYY?
- Then, what TCP port number needs to be forwarded?
- How many entries am I going to make in the Port Forwarding table?

Please bear with me. Even though I'm an Electrical Engineer by degree, my illness is attacking the grey matter and making cognitive understanding difficult. I think this one last step and I'll be remotely operating from the hospital the next time I get admitted. At least, that is my goal.

Thanks for your help folks! I couldn't do this without you all.

73, Dave K4EET

[Edit #1]: I am running SmartSDR Version 2.0.17
[Edit #2]: This is a continuation of https://community.flexradio.com/flexradio/topics/need-help-with-verizon-actiontec-mi424wr-router which obviously I still have not done the router setup completely right yet.
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
  • somewhat frustrated...

Posted 1 year ago

  • 2
Photo of Mark Thomas

Mark Thomas

  • 51 Posts
  • 15 Reply Likes
Hi Dave,

For SmartLink you need two public Internet ports forwarded to the inside LAN (192.168.1.x) IP address of your radio base. If your router supports uPNP, then this can be done automatically by the radio, otherwise you would need to configure your router manually.

public UDP port 4993 forwarded to your radio UDP port 4993

public TCP port 4994 forwarded to your radio TCP port 4994

That is a total of two port forwarding table entries.

Hope this helps.  -Mark KC3DRE
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Ria, where do I find the app that you displayed above with Network Settings? I've never seen that before. I'm wondering if that is the missing puzzle piece to make this work remotely. It appears to be set up that way in the router screenshot below but I'm curious to know where that window comes from. Thanks! Dave K4EET
Photo of Danny K5CG

Danny K5CG

  • 316 Posts
  • 46 Reply Likes
David, from the SmartSDR Startup page click on the SmartLink Setup button bottom right.
Then click on the down arrow to the left of "Network Settings".
If you are currently on Auto or Manual, try the test button.
You can try the Automatic (UPnP) mode or Manual mode and see if you get a green light by the Test button.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2273 Posts
  • 911 Reply Likes
Yep. And if you are doing the manual port forward, make sure you select manual. It may work if you just leave it in auto and manually port forward, or it may not. Best to do it the way that is recommended. 
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
I don't have a SmartLink setup button on my SmartSDR StartUp Page. See screenshot...
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Solved the problem. You have to highlight the radio before the SmartLink buttons appear. Then I found out that this part had never been set up nor had the radio been registered. All is complete now. The next step is to wait for my wife to drive me to a few locations to see if I can now remotely access the radio. Thanks for your help Ria and Danny! This may have been the missing link. Thanks again! 73, Dave K4EET

[Edit] Here is the SmartLink Network Settings:
(Edited)
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Thanks for the replies. Look at the screenshot in this post:
https://community.flexradio.com/flexradio/topics/need-help-with-verizon-actiontec-mi424wr-router
Those two ports were set up automatically by the SmartSDR install package.

But there still seems to be something else that I need to do in the router to operate remotely. I'll see if I can find the reference that either Tim or Dudley made that I could not figure out.

73, Dave K4EET
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2273 Posts
  • 911 Reply Likes
Dave -

Based on that thread, I'm not even sure where the problem is.

Are you able to connect at all? 

Are you connecting in "remote" mode and making sure you disconnect the radio at home first? If you connect while another client is connected you can use "remote" mode only where you will only be able to control the radio but you get no feedback as far as waterfall, panadapter etc is concerned. The best solution is to disconnect the radio from another client such as a PC or Maestro and then connect ONLY with the iPhone. There can only be one client connected at a time.

Also make sure you are using only one router. Due to the way some ISPs like FiOS operate and require you to use their underpowered router, some people choose to add a router AFTER it and do double NAT. This will simply not work for SmartLink. Another switch is fine. Another router is not.

If you are getting audio but no waterfall/panadapter, the router may not be passing fragmented packets. This is a problem in the router that they (ISP) may need to fix. Sometimes it's a problem in the client end. One of the wifis I use at work has this issue and the IT department has been unhelpful (I know the issue, they deny what it is, and they refuse to fix it.)

Over to you.
Ria
Photo of Danny K5CG

Danny K5CG

  • 316 Posts
  • 46 Reply Likes
Are you absolutely certain the IP address of your Flex is 192.168.1.10?
Your subnet mask and gateway are correct?

Settings->Radio Setup... Network Tab.


If you are going to use manual port forwarding then the radio must be setup with Static IP settings (not DHCP).
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Ria, everything works fine on my home network when the iPhone is connected to the router via the router's Wi-Fi. It is just when I am away from home and either at some place that has Internet connectivity via Wi-Fi or local to Verizon's 3G, 4G or LTE networks. 73, Dave K4EET
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2273 Posts
  • 911 Reply Likes
I would either use UPnP or do the port forwarding exactly as SmartSDR recommends, regardless of what "just works" for others. The reason being that you want a supported configuration and this removes yet another variable.

I also agree about double checking the IP of the radio. I would recommend static DHCP so that it remains consistent with router changes.
Photo of Jim Gilliam

Jim Gilliam

  • 880 Posts
  • 191 Reply Likes

The two ports are listed as the port numbers that you have to install in your router. You must be able to access your router to do this. Most routers have an address of 192.168.1.1 or something very similar. You access your router by entering that IP address into a program like Internet Explorer. Once you address the router you should get a page where you have accessed and can, now, port ward the router. Usually this is done under a WAN heading. All routers are different in the way you access the page to perform the necessary port forwarding.


Jim, K6QE

Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
To all of the above:

The first screenshot is my router's Port Forwarding section. The two lines that reference FlexRadio were set up automatically during the SmartSDR Version 2.0.17 installation process. The second screenshot is the Settings ---> Radio Setup... ---> Network tab. I entered the information in the lower half of the dialog window and hit "Apply" upon which the radio rebooted. The radio's IP Address is definitely 192.168.1.10 on my home network.

Those are the ONLY settings that have been changed so far. Is there one or more settings that need to be changed either in the Actiontec MI424WR router, my Norton Security software or elsewhere? Please be specific. Thanks for your assistance!

73, Dave K4EET


Photo of Danny K5CG

Danny K5CG

  • 316 Posts
  • 46 Reply Likes
Yes, that all looks to be in order.
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Danny, it may all look to be in order but I'm still stuck in the "Discovering..." mode when trying to connect remotely. Something is missing somewhere... 73, Dave K4EET
Photo of Danny K5CG

Danny K5CG

  • 316 Posts
  • 46 Reply Likes
The only thing I can think of is to split the problem in half by trying to log in to another Flex user's radio with your client setup, and setting up another user to log into your radio with theirs. See which half is the problem.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2273 Posts
  • 911 Reply Likes
Dave, if you want to try my radio, I can give you credentials. I am good in QRZ. ALthough from all that has been said it looks like misconfiguration on the server (radio) end. 
Photo of k3Tim

k3Tim

  • 857 Posts
  • 167 Reply Likes
"everything works fine on my home network when the iPhone is connected to the router via the router's Wi-Fi."  

Next step is to try connecting with the iFone not using WiFi. 
Could the problem be the ISP isn't allowing the ports thru?
Photo of Rev. David E. Hamm, K4EET

Rev. David E. Hamm, K4EET

  • 83 Posts
  • 13 Reply Likes
Thanks to everybody that helped me on this topic. It turned out that I had never registered my radio with the SmartLink Network Setup. This just might be the missing link that was keeping the remote operations from working correctly. I'll know for sure the next time my wife takes me somewhere that I can try out the remote capability. The FlexRadio Community is the BEST! Thanks again to all! 73, Dave K4EET

[Edit] Here is the SmartLink Window that was previously not set up. The radio was not even registered. My bad...
(Edited)
Photo of Ed, K0KC

Ed, K0KC

  • 269 Posts
  • 19 Reply Likes
Dave,

You should be able to test your setup at home by turning-off wi-fi on your phone and trying to connect using LTE. I have done this several times previously when testing.

Ed, K0KC