Removing 1.4.x to Load 1.6.x - Remove Flex VSP ?

  • 1
  • Question
  • Updated 3 years ago
This may seem rather basic but before upgrading to rel 1.6.x, I was going to remove my current 1.4.x but I see two files, Flex VSP and SmartSDR v 1.4.16.
I was going to remove the SSDR v 1.4.16 but shall I also remove the file Flex VSP?
Many Thanks es 73, Jim    
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes

Posted 3 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
If the FlexVSP version is 1.0.2, you can leave it.

Just remove the 1.4 and 1.5 versions of SmartSDR.

On the last version you uninstall, answer NO the the question if you want to keep the DAX drivers.  This will remove them.  Reboot your PC and then install SmartSDR v1.6.17
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Thank you for all your support and patience with these basic questions, Tim.      73, Jim
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Tim, the plot thickens.   I did as suggested and then loaded rel 1.6.17.   OK, so far. It behaves like a real radio.....SSB works. It receives and transmits just fine.

However, my FLDIGI will not show audio on transmit or receive. It does provide rig control and will put the Flex into transmit (no output of course)  FLDIGI and Logger 32 both provide control of the frequency just fine.   Let me give an overall description of events and observations.

First, during installation, it asked if I wanted to load dev SW; Flex Radio Systems Sound, video and games.     I selected yes and it repeated this three more times until Windows popped up with a Program Compatibility Assistant which warned "Windows requires a digitally signed driver. A recently installed program tried to install an unsigned driver........etc.         I tried once more and it seemed to just accept the drivers. Not sure about this however.

Next, once everything was installed and rebooted the DAX and CAT control panels came up.
The DAX panel shows "TX Stream driver error" "Mic Stream driver error" and "Rx streams Slice A driver error".      They both show actual audio for receive and transmit on the strip meters.

The CAT panel v 1.6.17 shows COM5 and COM 7 twice. The second instance indicates an error next to the com port number ( 5 & 7).     Can I just remove the second instance; the ones that indicate an error?

So I seem to have an issue with DAX but I'm not sure just what to do about it.   Many Thanks again, Jim              KD1I
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
James - we are going to need to do some more detailed investigations, so I suggest you submit a support ticket via our HelpDesk (http://helpdesk.flexradio.com) so we can assign you a case number.  For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...   Once the support ticket is submitted, a support engineer will be in contact so we can work on the issue.
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Hi Tim. OK, I will do that right now. Thanks for the reply. I know you must be very busy with this new release. 73, Jim
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Tim, I am having an impossible time logging in.   I do not recall my password so I clicked on 'forgot password'.    This is getting me no where. I just directs me to sign in which has me running in circles. Next, I tried a new login but it recognizes me as an existing user so it wants me to just reset my password. I can't seem to proceed.
Suggestions?       Jim
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
OK, I found my old password and submitted a case. I hope it is a logical description. 73, Jim
Photo of Rob Fissel

Rob Fissel

  • 270 Posts
  • 47 Reply Likes
Just to add into the discussion here, I had no issues in Win 7 Pro (completely up to date). Uninstalled 1.5.1, rebooted box and rig, installed 1.6.17 without a hitch. 

On Win 8.1 Pro (work computer), uninstalled 1.5.1, rebooted box, and installed 1.6.17. CAT wouldn't start, stating it needed FlexVSP running to work. I checked FlexVSP in "Uninstall Programs" to find that it showed it's installation date to be the same date as when in had installed 1.5.1 way back when. Needed to manually uninstall FlexVSP, and then rerun the FlexVSP installation from the FlexVSPInstaller_64 windows installer package. No big deal, but a little odd. 
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
I have uninstalled the new release, upgraded Win 7 many times, rebooted each time and reinstalled SSDR 1.6.17.........several times but each time the results are the same.   Still says the drivers are unsigned.   I even tried saying "NO" to the driver load but of course that did not resolve the issue. So after each reload, the radio works fine for CW and SSB but no DAX....just lots of errors.
I did open a ticket and I have been working with Dudley on this. So far, I have tried what he suggested many times just in case.......    but no resolution.
I suppose I could try this laptop which runs Win 10 just to test it out..... Good project for a Saturday morning.     73, Jim