Question about FlexLib Versions

  • 1
  • Question
  • Updated 10 months ago
  • Answered
I notice the 2.0.19 FlexLib but don't see a library for the latest 1.x. Is the 1.x code now using the 2.x library minus 2.x features?

73,
Kev K4VD
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes

Posted 10 months ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
We maintain only one FlexLib API and that is for the latest and highest version of SmartSDR that has been released, in this case, v2.0.19.

Any new feature enhancement that might be included in v1.x will also be included in v2.x

You can use this API for projects where radios are running 1.x code.  However, there may be features in the latest API that are not supported on 1.x and in that case they just do not work (it would be interpreted by the radio as an invalid command).  So as a developer, if you use features that are version specific, you need to address those use cases in your code
(Edited)