Question about DAX Audio TX...

  • 1
  • Question
  • Updated 2 months ago
I powered up the 6500 for the first time in a while this week. I've been curious about FT-8 and wanted to get back in touch with some of the digital modes. I updated SSDR, the radio (2.4.9), and re-installed the latest WSJT-X and FLDIGI. It all seems to be working well but there's something different about DAX that I don't understand or remember from before.

When I first set things up in both FLDIGI and WSJT-X I had the TX audio set to:

DAX Audio TX

Now I see two DAX Audio TX but named a little differently:

DAX Audio TX (FlexRadio Systems DAX IQ)
DAX Audio TX (FlexRadio Systems DAX TX)

I can only get WSJT-X and FLDIGI to work with the one that says FlexRadio Systems DAX IQ. What is this? I never noticed TX being associated with IQ and I don't remember seeing two DAX Audio TX options available.

From WSJT-X


From fldigi
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes

Posted 2 months ago

  • 1
Photo of John M5ET

John M5ET

  • 22 Posts
  • 0 Reply Likes
Looks like you're hitting the latest fun 'feature' with Windows 10 - are you running the 1809 update, by any chance?

Jay NO5J sorted this out for me last night, and I'm halfway through writing a guide on how to fix it, it's a case of a mis-named driver somewhere in there.

If you head over to the IRC channel, he and I are both there, and one of us should be able to help you through it.

73,
John (M5ET)
Photo of Johan / SE3X

Johan / SE3X

  • 76 Posts
  • 32 Reply Likes
You are fine John. Worked you as SE3X just a bit earlier on 40m. Great signals as well :)
Photo of John M5ET

John M5ET

  • 22 Posts
  • 0 Reply Likes
Was good to work you. Your callsign stuck in my head, unlike some of the others I'd worked!!! Very distinctive.

73,
John (M5ET)
Photo of Johan / SE3X

Johan / SE3X

  • 76 Posts
  • 32 Reply Likes
Tnx! Yes it has been a nice call in both DX and contest since 2012. Seem's to stick and attract a bit of interest. 
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes
Hi John. Yep. Running W10 1809 17763.195.

Can't jump on the IRC right now (don't have the link either) but I would be happy to be your first test case for the guide you're writing.

Kev

Photo of Neal Pollack, N6YFM

Neal Pollack, N6YFM

  • 178 Posts
  • 81 Reply Likes
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes
I did a complete uninstall of DAX. Confirmed no ghosts. Re-installed.

Now  both capture and playback names have been changed.

To make fldigi work, Capture is set to:

DAX RESERVED AUDIO TX (FlexRadio Systems DAX IQ)

Playback:

DAX RESERVED AUDIO RX 1 (FlexRadio Systems DAX IQ)

To find these, I had to cycle through each of the port options until I found the combination that works.

I had to change WSJT-X to the same.

Photo of John M5ET

John M5ET

  • 22 Posts
  • 0 Reply Likes
Yep, you still have the issue. You've got IQ devices labelled as "AUDIO TX" and "AUDIO RX".

Once I get the guide written it'll all make sense, but essentially you need to rename those devices correctly to get everything to behave itself.

John (M5ET)
Photo of Don, VE2HJ

Don, VE2HJ

  • 37 Posts
  • 2 Reply Likes

Hi Kevin. 

May be you should look at this post :


     Most Common Fix for DAX Driver errors in Windows Spring Update (1803) (You can do this!)

Hope it help.

Don , VE2HJ
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes
I will try this next time Don. For now, I think I have everything matched up. I went through a previous procedure to uninstall all DAX drivers. Actually, I uninstalled them a few times just for OCD sake.

Then I reinstalled. Uninstalled again. Reinstalled and I think on the third or fourth try everything lined up. I rebooted between each install. I noticed at each try different interfaces were missing or misnamed.

WSJT-X audio setup now looks normal to me:


and I think all the names look OK in Device Manager.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes
Spoke too soon. After all the uninstall/installs my default device was set to dax reserved audio rx 8. When I set it to my desk speakers I could no longer transmit.
Photo of Neal Pollack, N6YFM

Neal Pollack, N6YFM

  • 178 Posts
  • 81 Reply Likes
Open a ticket.
Tim will help.