Problem Solved with iPad & SmartSDR for iOS w/Help from Marcus

  • 5
  • Praise
  • Updated 1 year ago
I was being driven to the brink trying to solve a weird problem where my iPad Pro acted differently than my iPhone 6 while using SmartSDR for iOS.

Both devices USED TO work very well and acted the same.  Then, one day, my iPad wouldn't find any radios using the "Discover" option.  The iPhone still behaved normally.  I tried all sorts of messing around trying to restore my iPad to its previous wonderful operation.  No dice.

I e-mailed the app author, Marcus, and he was very helpful in making suggestions as to what might be the trouble.  I told him it seemed to me that there was something wrong, buried in the iPad that was messing up the connection.  After many cycles of removing and re-installing the app, I sort of accused his app of leaving something behind in a hidden file that was not being removed.

Marcus spent quite a bit of time checking his code and patiently teaching me that iOS cannot leave any hidden files after removing an app.  We then looked at networking and router configurations thinking something had gone wrong that was blocking UDP traffic to the iPad.  I upgraded the firmware in my Draytek Vigor 3900 and the subsequent restart re-arranged all the DHCP leases to new IP addresses and still nothing improved.  Darn!

Then, quite by accident I decided to try K6TU's iPad app (I was an early adopter) to see if it had any problem.  I discovered that the subscription had expired since the last time I used it and it displayed a message that said "no radios found".  Darn --- same problem.

Just for fun, I decided to un-install Stu's app and low and behold, SmartSDR for iOS immediately returned to its old glory, working exactly like it used to.  When the K6TU app had a current subscription, it and SmartSDR for iOS coexisted peacefully for a very long time with no problems at all.  It was only after the subscription expired that the K6TU app appeared to hang up other apps trying to use Flex UDP broadcast traffic.

After all the time and effort I and Marcus spent trying to fix the problem, I was not very amused to find the culprit to be caused by an expired app.

I want to publicly thank Marcus for being so helpful and responsive.  I really appreciate all his efforts.
Photo of Mike - W8MM

Mike - W8MM

  • 220 Posts
  • 50 Reply Likes

Posted 3 years ago

  • 5
Photo of Lee - N2LEE

Lee - N2LEE

  • 320 Posts
  • 167 Reply Likes
Marcus is fantastic and I love he is always looking for new ideas to improve his software.
Photo of Tom Koch

Tom Koch

  • 3 Posts
  • 0 Reply Likes
I just installed Marcus’s app and it connects quickly and I can remotely control my Flex 6300 but I don’t get the panadapter or any audio on the iPhone or iPad, The Demo shows the panadapter and received audio but not whe. Connected via Smartlink!
Photo of Brian - W9HLQ

Brian - W9HLQ

  • 58 Posts
  • 15 Reply Likes
I had the same problem....   my iPad would connect with the Scan option....    This problem showed up overnight as I have been using the iPad for months with no problem until now.  Deleting the K6TU app fixed the problem

==Brian, W9HLQ==
Photo of Wayne


  • 614 Posts
  • 89 Reply Likes
What is the K6TU app?
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1493 Posts
  • 327 Reply Likes
It was an app available to remotely control and operate the radio before SmartLink existed.
I believe it is no longer available on the app store.

Dave wo2x